Unable to create a project when I check out the contents of a repository

Bug #314893 reported by Alex Bleasdale on 2009-01-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Plugin for Eclipse
High
Piotr Piastucki

Bug Description

I seem to be currently unable to check out a Bazaar repository as a new project - so I'm unable to use the plugin..

Steps to reproduce this:

New > Project > Checkout as new project

Enter my local bzr repository location (bzr://localhost/test/trunk)

[Use the project wizard] greyed out - so I select Create a Project and leave Tip selected for the revision.

Then when it comes to entering a project name, nothing enables the next button. Pic attached.

I'm using Eclipse 3.4.1 and bzr-eclipse with bzr-xmloutput-0.8.2 and bzr 1.10 on OSX 10.5.6

Guillermo Gonzalez (verterok) wrote :

Hi Alex,
Thanks for reporting this, I just tried to create a project from a branch and all worked ok (screenshot attached).

Could you please attach the logs generated when you try to use the wizard?, the log file can be found at <WORKSPACE>/.metadata/.log

Thanks!

Changed in bzr-eclipse:
status: New → Incomplete

I see the same problem when entering the project name, the only button enabled is the back button.

I am on windows xp. There is also a problem before that on the select the from branch. I select the browse button, find the branch, when I get back the value is:
next button disabled with Y:\bazaar\project

But if I change it to forward slashes I get
next button enabled with Y:/bazaar/project

but when I get to the screen to name the branch, nothing enables the next or finish buttons. This all works fine on linux for me.

Hope I'm not hijacking this other guy's bug, but I do see some of the same symptoms.

I was able to checkout on windows if I specified the from branch as

file://y:/bazaar/project

So, the browse filesystem function is broken on windows, but it would seem that if it can find a valid branch that I do not see a problem with the name project panel.

John,

Thanks for the follow up.

On Wed, May 6, 2009 at 6:10 PM, John Nistler <email address hidden> wrote:
> I was able to checkout on windows if I specified the from branch as
>
> file://y:/bazaar/project
>
> So, the browse filesystem function is broken on windows, but it would
> seem that if it can find a valid branch that I do not see a problem with
> the name project panel.
>

Ok, so the problem seems to be that when the branch isn't valid the
project name page never enable the next button.
As Alex said, the error also occurs with bzr:// scheme.

Thanks for the testing!

Cheers
> --
> Unable to create a project when I check out the contents of a repository
> https://bugs.launchpad.net/bugs/314893
> You received this bug notification because you are a member of bzr-
> eclipse developers, which is subscribed to Bazaar Plugin for Eclipse.
>
> Status in Bazaar Plugin for Eclipse: Incomplete
>
> Bug description:
> I seem to be currently unable to check out a Bazaar repository as a new project - so I'm unable to use the plugin..
>
> Steps to reproduce this:
>
> New > Project > Checkout as new project
>
> Enter my local bzr repository location (bzr://localhost/test/trunk)
>
> [Use the project wizard] greyed out - so I select Create a Project and leave Tip selected for the revision.
>
> Then when it comes to entering a project name, nothing enables the next button.   Pic attached.
>
> I'm using Eclipse 3.4.1 and bzr-eclipse with bzr-xmloutput-0.8.2 and bzr 1.10 on OSX 10.5.6
>

Changed in bzr-eclipse:
importance: Undecided → High
status: Incomplete → Triaged
Changed in bzr-eclipse:
milestone: none → 1.2
Changed in bzr-eclipse:
status: Triaged → Fix Committed
assignee: nobody → Piotr Piastucki (piastucki)
Alexander Taler (alex-idereal) wrote :

The new project wizard should resolve these issues.

Changed in bzr-eclipse:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers