Unable to kick off a merge

Bug #294061 reported by Eric on 2008-11-05
2
Affects Status Importance Assigned to Milestone
Bazaar Plugin for Eclipse
High
Guillermo Gonzalez
Java library for Bazaar
High
Guillermo Gonzalez

Bug Description

I created a test repository (A) with a couple of files in it then created a branch (B) from it using the Eclipse plugin Team -> Branch command. If I modify a file in B and commit it then I am able to call Team -> Merge on A to get the modification into A. However if I modify a file in A and commit it then when I call Team -> Merge on B I don't even get the "Remote location Dialog" box and nothing happens ! I am able to do the merge using the "bzr merge" command from the command line. Is this a bug or is there something I am doing incorrectly ?

I am working with Eclipse Gannymede 3.4.1 (for C/C++), Bazaar 1.7rc2 and version 1.1.1 of the bzr-eclipse plugin.

Related branches

Eric (eric-dangoor) wrote :

I have attached a zip file containing the Eclipse workspace which contains the 2 branches

Eric (eric-dangoor) wrote :

I tried playing around and found that if I remove the line

parent_location = file:///c:/Documents%20and%20Settings/dangoore/My%20Documents/EclipseBZRWorkspace/MyProject/

from the file ...\MyProjectBranch2\.bzr\branch\branch.conf (and restart Eclipse) then when I do a Team -> Merge I at least get the "Remote location Dialog" box. This was purely by trial and error trying to make the 2 branches look identical. I have no idea what the significance of doing this is.

Guillermo Gonzalez (verterok) wrote :

Thanks for reporting this.
It seems there is a problem with the spaces on the path.

Changed in bzr-eclipse:
importance: Undecided → High
status: New → Confirmed
Guillermo Gonzalez (verterok) wrote :

The problem occurs when the specified string is not correctly escaped.
java.net.URI don't make the escaping itself.

Changed in bzr-java-lib:
assignee: nobody → verterok
importance: Undecided → High
status: New → Confirmed
Changed in bzr-java-lib:
status: Confirmed → Fix Committed
Changed in bzr-eclipse:
assignee: nobody → verterok
status: Confirmed → Fix Committed
Changed in bzr-eclipse:
status: Fix Committed → Fix Released
Changed in bzr-java-lib:
status: Fix Committed → Fix Released
AnkurD (ankurd) wrote :

This is still causing problems in linux.
CommandLineException is raised if file path contains spaces.

----------------------------------------------------
Exception in thread "main" org.vcs.bazaar.client.commandline.CommandLineException: <?xml version="1.0" encoding="UTF-8"?><error><class>NotBranchError</class><dict><key>path</key><value>/home/ankur/ank%20d/</value><key>extra</key><value></value><key>detail</key><value></value></dict><message>Not a branch: "/home/ankur/ank%20d/".</message></error>
        at org.vcs.bazaar.client.commandline.internal.Command.execute(Command.java:83)
        at org.vcs.bazaar.client.commandline.CommandLineClient.run(CommandLineClient.java:639)
        at org.vcs.bazaar.client.commandline.CommandLineClient.run(CommandLineClient.java:633)
        at org.vcs.bazaar.client.commandline.CommandLineClient.info(CommandLineClient.java:495)
        at test.main(test.java:21)
        at org.vcs.bazaar.client.commandline.CommandLineClient.run(CommandLineClient.java:633)
        at org.vcs.bazaar.client.commandline.CommandLineClient.info(CommandLineClient.java:495)
        at test.main(test.java:21)
Caused by: java.io.IOException: <?xml version="1.0" encoding="UTF-8"?><error><class>NotBranchError</class><dict><key>path</key><value>/home/ankur/ank%20d/</value><key>extra</key><value></value><key>detail</key><value></value></dict><message>Not a branch: "/home/ankur/ank%20d/".</message></error>
        ... 8 more
-----------------------------------

This is maybe due to the fact that on unix ' ' doesnt have to be replaced by '%20'.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions