Eclipse hangs in bazaar operations that require user input

Bug #121936 reported by Guillermo Gonzalez on 2007-06-23
52
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Bazaar Plugin for Eclipse
High
Piotr Piastucki

Bug Description

Commands that require authentication or unexpected (by bzr-eclipse) input hangs Eclipse.

This happen because there is no way to tell Bazaar the user and password to use from the command line.

There is a Blueprint (https://blueprints.launchpad.net/bzr/+spec/authentication-ring) which (when implemented) should allow bzr-eclipse to execute commands that require authentication.

description: updated
Changed in bzr-eclipse:
importance: Undecided → High
status: New → Confirmed
Guillermo Gonzalez (verterok) wrote :

there is a partial workaround (at least in *nix systems), which is the use of ssh-agent/ssh-askapass for sftp connections.

Vincent Ladeuil (vila) wrote :

1) Have a look at bzrlib.ui and implements your own get_password
2) Embedding user and password in url will avoid bzr prompting for a password

Changed in bzr-eclipse:
status: Confirmed → Triaged

My Eclipse hung when I had to accept the hostkey for bazaar.launchpad.net - that is similar problem but not related to passing user/pass credentials - I think.

Hi Niklas,
Thanks for your comments,
this is not strictly user/pass input, but is user input.
This is the same problem that happen when ssh ask your passphrase, bzr
spawns a ssh subprocess and this process is the one that waits for
user input.

I'm trying to find a way to solve this issue.

Regards,

On Wed, Sep 17, 2008 at 4:32 PM, Niklas Andersson
<email address hidden> wrote:
> My Eclipse hung when I had to accept the hostkey for
> bazaar.launchpad.net - that is similar problem but not related to
> passing user/pass credentials - I think.
>
> --
> Eclipse hangs in bazaar operations that require user input
> https://bugs.launchpad.net/bugs/121936
> You received this bug notification because you are a member of bzr-
> eclipse developers, which is subscribed to Bazaar Plugin for Eclipse.
>
> Status in Bazaar Plugin for Eclipse: Triaged
>
> Bug description:
> Commands that require authentication or unexpected (by bzr-eclipse) input hangs Eclipse.
>
> This happen because there is no way to tell Bazaar the user and password to use from the command line.
>
> There is a Blueprint (https://blueprints.launchpad.net/bzr/+spec/authentication-ring) which (when implemented) should allow bzr-eclipse to execute commands that require authentication.
>

Norm 2782 (norm2782) wrote :

Hi. How's a fix for this issue coming along? We're experiencing it too and it's a roadblock in adopting Bazaar as a VCS : )

Guillermo Gonzalez (verterok) wrote :

Hi Norm,
I wasn't able to get the free time to fix this, also it depends on big changes to the xmloutput plugin.

What problem are you hitting?
Maybe we can find a workaround for it

Regards,

Norm 2782 (norm2782) wrote :

Hi Guillermo,

Sorry for the late response. I wasn't notified by Launchpad that there was a reply in this thread :)
We've decided to stick with our existing Subversion setup for now, so I can't really recall the details of the issue anymore. We will revisit Bazaar with the open sourcing of Launchpad in a few months. If the issue is still open by that time I'll be glad to help you find some workarounds :)

Cheers

Archimedes Trajano (trajano) wrote :

The blueprint says it is "implemented" already.

Just wondering though, is it possible to make BzrEclipse use the SSH implementation that is already present with Eclipse? I was thinking having passing an override on the SSH implementation used by Bazaar that calls upon Eclipse instead.

xaav (xaav) wrote :

To do that, you would have to do something like jbzr. Right now, bzr-eclipse uses the native installation, so It is getting it's SSH settings from the environment.

Changed in bzr-eclipse:
milestone: none → 1.2
Changed in bzr-eclipse:
assignee: nobody → Piotr Piastucki (piastucki)
status: Triaged → In Progress
Changed in bzr-eclipse:
status: In Progress → Fix Committed
Alexander Taler (alex-idereal) wrote :

In my recent attempts I was unable to reproduce this.

Changed in bzr-eclipse:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers