unexpected keyword argument 'pb'

Bug #788914 reported by Brook Stevens on 2011-05-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
CVS to Bazaar importer
Critical
Unassigned
bzr-cvsps-import (Ubuntu)
Critical
Jelmer Vernooij

Bug Description

Using a fresh install on Bazaar 2.3.1, Ubuntu 11.04 (GNU/Linux 2.6.38-8-virtual x86_64)
  Python interpreter: /usr/bin/python 2.7.1
  Python standard library: /usr/lib/python2.7
  Platform: Linux-2.6.38-8-virtual-x86_64-with-Ubuntu-11.04-natty
Crash:

bzr: ERROR: exceptions.TypeError: open_or_create_bzr_repo() got an unexpected keyword argument 'pb'

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 926, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1126, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 691, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 713, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/home/ubuntu/.bazaar/plugins/cvsps_import/__init__.py", line 102, in run
    importer.process()
  File "/home/ubuntu/.bazaar/plugins/cvsps_import/cvsps/importer.py", line 1277, in process
    repo = self.open_or_create_bzr_repo(pb=pb)
TypeError: open_or_create_bzr_repo() got an unexpected keyword argument 'pb'

Brook Stevens (brook) wrote :

I am unsure of the reason for passing in pb=pb but removing it fixed the issue. This fix is in this branch, but someone should review it:
lp:~brook/bzr-cvsps-import/fix-402690-788914-788915

Martin Pool (mbp) wrote :

I guess cvsps-import is out of date with bzr and needs to be just taught not to pass that parameter. (Would need to check.) I'm surprised this has not shown up on lp.

Changed in bzr-cvsps-import:
importance: Undecided → Critical
status: New → Confirmed

thanks very much! please propose it for merging into the trunk, when
you're ready.

Brook Stevens (brook) wrote :

Done. It has some other changes if you want I am happy to separate them out into separate branches.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/27/2011 03:55 AM, Martin Pool wrote:
> I guess cvsps-import is out of date with bzr and needs to be just taught
> not to pass that parameter. (Would need to check.) I'm surprised this
> has not shown up on lp.
>
> ** Changed in: bzr-cvsps-import
> Importance: Undecided => Critical
>
> ** Changed in: bzr-cvsps-import
> Status: New => Confirmed
>

I think you are thinking of cscvs. This is cvsps, which is not very
actively maintained. (For about 1-2years now.)

John
=:->
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk3fXvAACgkQJdeBCYSNAAOBxwCgjCy9yflGAk33Lalu2rfWAP3Y
QzAAoJWXMY5rzIvkFzOIabo5Rz9u4W1C
=v0tk
-----END PGP SIGNATURE-----

Jelmer Vernooij (jelmer) on 2011-06-28
Changed in bzr-cvsps-import:
status: Confirmed → Fix Committed
Jelmer Vernooij (jelmer) on 2011-12-09
Changed in bzr-cvsps-import (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Jelmer Vernooij (jelmer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-cvsps-import - 0.0.1~bzr69-1

---------------
bzr-cvsps-import (0.0.1~bzr69-1) unstable; urgency=low

  * New upstream snapshot.
   + Fixes compatibility with newer versions of bzr. LP: #788914

 -- Jelmer Vernooij <email address hidden> Fri, 09 Dec 2011 21:30:37 +0100

Changed in bzr-cvsps-import (Ubuntu):
status: Triaged → Fix Released
Jelmer Vernooij (jelmer) on 2012-03-22
Changed in bzr-cvsps-import:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers