{debupstream} {debversion} not recognised by format 0.4

Bug #1350430 reported by LocutusOfBorg on 2014-07-30
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
bzr-builder
Critical
William Grant
launchpad-buildd
Critical
William Grant

Bug Description

After the deploy of the new format level seems that debupstream has been lost

https://code.launchpad.net/~costamagnagianfranco/+recipe/boinc-upstream-daily
# bzr-builder format 0.4 deb-version {debupstream}~~git{date}+r{revno}~r{revno:packaging}
lp:boinc-upstream
nest-part packaging lp:~costamagnagianfranco/+junk/boinc-upstream-merge debian debian

build failure
https://launchpadlibrarian.net/181070053/buildlog.txt.gz

Committed revision 21927.
bzr: ERROR: bzrlib.errors.BzrCommandError: Invalid deb-version: {debupstream}~~git20140730+r21926~r184~ubuntu14.04.1: Invalid version string '{debupstream}~~git20140730+r21926~r184~ubuntu14.04.1'

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builder/cmds.py", line 376, in run
    append_version=append_version)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builder/deb_util.py", line 223, in add_autobuild_changelog_entry
    % (version, e))
BzrCommandError: Invalid deb-version: {debupstream}~~git20140730+r21926~r184~ubuntu14.04.1: Invalid version string '{debupstream}~~git20140730+r21926~r184~ubuntu14.04.1'
resource.struct_rusage(ru_utime=7.075995, ru_stime=1.124232, ru_maxrss=168708, ru_ixrss=0, ru_idrss=0, ru_isrss=0, ru_minflt=57528, ru_majflt=11, ru_nswap=0, ru_inblock=7000, ru_oublock=245824, ru_msgsnd=0, ru_msgrcv=0, ru_nsignals=0, ru_nvcsw=5046, ru_nivcsw=950)

Related branches

Erich E. Hoover (ehoover) wrote :

Seeing the same problem with "debversion":
bzr: ERROR: bzrlib.errors.BzrCommandError: Invalid deb-version: {debversion}~daily-201407300231~ubuntu12.04.1: Invalid version string '{debversion}~daily-201407300231~ubuntu12.04.1'

summary: - {debupstream} not recognised by format 0.4
+ {debupstream} {debversion} not recognised by format 0.4
Jelmer Vernooij (jelmer) wrote :

This is intentional behaviour. In format 0.4, you have to specify the name of tree explicitly if you'd like to get the version from one of the nested trees.

e.g. {debversion:packaging} rather than {debversion}.

IIRC the reason for this is so that bzr-builder can determine the version string without having to build the full tree.

Jelmer Vernooij (jelmer) wrote :

(I'd mark this as wontfix, but I no longer have permissions to do so)

Erich E. Hoover (ehoover) wrote :

My recipe is still in format 0.3 (https://code.launchpad.net/~pipelight/+recipe/wine-compholio-daily):
# bzr-builder format 0.3 deb-version {debversion}~daily-{time}

So it's not just that the new format is different, the old format isn't recognized. I'm happy to update to the new format so that my daily builds work again, but this probably is affecting others as well.

William Grant (wgrant) on 2014-08-01
Changed in launchpad-buildd:
importance: Undecided → Critical
status: New → Triaged
tags: added: regression
Jasem Mutlaq (mutlaqja) wrote :

Yes, I can confirm this is affecting 0.3 as well. All my packages fail to build now.

Raimar Sandner (raimar-sandner) wrote :

I tried the solution in comment #2 but it still fails the same way. This is my recipe:

# bzr-builder format 0.4 deb-version {debversion:build}+{time}
lp:~raimar-sandner/+junk/cppqed_Development
nest build lp:~raimar-sandner/+junk/cppqed.precise_daily debian

William Grant (wgrant) on 2014-08-05
Changed in launchpad-buildd:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Changed in bzr-builder:
assignee: nobody → William Grant (wgrant)
importance: Undecided → Critical
status: New → In Progress
William Grant (wgrant) on 2014-08-06
Changed in bzr-builder:
status: In Progress → Fix Committed
Changed in launchpad-buildd:
status: In Progress → Fix Committed
Jasem Mutlaq (mutlaqja) wrote :

I'm still getting this:

bzr: ERROR: bzrlib.errors.BzrCommandError: Invalid deb-version: {debversion}+r577.155~ubuntu14.04.1: Invalid version string '{debversion}+r577.155~ubuntu14.04.1'

and this is my receipe:

# bzr-builder format 0.3 deb-version {debversion}+r{revno}.{revno:packaging}
lp:libindi
nest-part cmake_module lp:~mutlaqja/libindi/cmake_modules . cmake_modules
nest-part packaging lp:~mutlaqja/libindi/packaging libindi debian

Any actual fixes or workarounds for this??

Colin Watson (cjwatson) wrote :

You're still getting this because we haven't rolled out the fixes yet.

Jasem Mutlaq (mutlaqja) wrote :

Thanks, any ETA on the release to live?

Jasem Mutlaq (mutlaqja) wrote :

Can anyone let us know WHEN the fix will be released?!!! If it is going to take a long time, then is there ANY workarounds to this bug? I need to get the packages built! :-(

William Grant (wgrant) wrote :

It was always possible to work around by using recipe format 0.4 instead of 0.3. But I've just deployed the fixes to make 0.3 recipes work correctly again.

Changed in launchpad-buildd:
status: Fix Committed → Fix Released
Jasem Mutlaq (mutlaqja) wrote :

I actually used 0.4 and got same errors.

Here is the recepie:

# bzr-builder format 0.4 deb-version {debversion}+r{revno}.{revno:packaging}
lp:libindi
nest-part cmake_module lp:~mutlaqja/libindi/cmake_modules . cmake_modules
nest-part packaging lp:~mutlaqja/libindi/packaging libindi debian

Error with debversion here:
https://launchpadlibrarian.net/183237070/buildlog.txt.gz

I tried changed {debversion} to {debversion:packaging} and got this:

https://launchpadlibrarian.net/183236870/buildlog.txt.gz

What am I doing wrong?

William Grant (wgrant) wrote :

0.4 changes the semantics of debversion, debupstream and debupstream-base when the branch name is omitted. Previously it would use the full built tree in that case, but now it just uses the base branch.

{deversion:packaging} doesn't work for you because your branches are structured oddly. It requires that the changelog exist as debian/changelog, but in your case it's libindi/changelog. You can't use debversion in 0.4 with your branch structure; you'll need to either revise your branch structure or continue to use 0.3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers