backtrace with 'bzr bd --package-merge'

Bug #812704 reported by Steve Langasek
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr-builddeb
Medium
Jelmer Vernooij

Bug Description

Trying to use bzr bd --package-merge in oneiric (bzr 2.4.0~beta5-2ubuntu1, bzr-builddeb 2.7.5) yields this backtrace:

$ bzr bd -S --package-merge
Building using working tree
Building package in normal mode
bzr: ERROR: exceptions.AttributeError: 'NoneType' object has no attribute 'upstream_version'

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1130, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 691, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 713, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/cmds.py", line 366, in run
    if (prev_version.upstream_version
AttributeError: 'NoneType' object has no attribute 'upstream_version'

bzr 2.4b4 on python 2.7.2 (Linux-3.0.0-5-generic-x86_64-with-
    Ubuntu-11.10-oneiric)
arguments: ['/usr/bin/bzr', 'bd', '-S', '--package-merge']
plugins: bash_completion[2.4b4], builddeb[2.7.0dev], changelog_merge[2.4b4],
    email[unknown], launchpad[2.4b4], netrc_credential_store[2.4b4],
    news_merge[2.4b4], weave_fmt[2.4b4]
encoding: 'ANSI_X3.4-1968', fsenc: 'ANSI_X3.4-1968', lang: None

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.
$

I've only recently discovered --package-merge, so I'm sad that it's been taken away from me so soon :)

Related branches

Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Jelmer Vernooij (jelmer)
Revision history for this message
Jelmer Vernooij (jelmer) wrote :

What package were you using --package-merge with?

Revision history for this message
Steve Langasek (vorlon) wrote :

This was lp:ubuntu/rpcbind -rtag:0.2.0-6ubuntu1. I figured out afterwards that it was a mistake to use --package-merge (I was trying to get around an archive reject caused by bug #810531), so it probably shouldn't do anything sensible here, but a clearer error message would be nice.

Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: In Progress → Fix Released
milestone: none → 2.7.6
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers