AptSource assumes packages are non-native

Bug #796853 reported by Jelmer Vernooij
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr-builddeb
Medium
Jelmer Vernooij

Bug Description

AptSource currently assumes that all packages it finds in the sources.list come with an upstream tarball. This isn't necessarily true, there are also packages (with dashes in their version) that don't come with an upstream tarball.

For example, Spamaps hit this issue with ensemble where the ensemble daily PPA had something like 0.5~daily4+ubuntu1 and bzr-builddeb assumed that meant it had access to the 0.5 tarball.

Related branches

Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: In Progress → Fix Committed
milestone: none → 2.8
Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: Fix Committed → Fix Released
milestone: 2.8 → 2.7.5
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers