should have a pre-commit hook to check that a v3 deb package has all patches applied

Bug #608670 reported by John A Meinel
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Distributed Development
High
Jelmer Vernooij
bzr-builddeb
High
Jelmer Vernooij

Bug Description

to assist packagers and developers, we would like to add a commit-time check, that they are committing with all patches applied.

If they were in the middle of the patch stack, then the WT would appear to remove all the changes from the other patches.

eg. changing the 3rd patch, should show up as only that simple change to the WT and a change to that one patch file.

Related branches

Revision history for this message
John A Meinel (jameinel) wrote :

Setting this to high because it helps ensure that package imports and udd packages stay in sync.

Changed in bzr-builddeb:
importance: Undecided → Low
status: New → Confirmed
importance: Low → High
Changed in udd:
importance: Undecided → High
status: New → Confirmed
Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: Confirmed → Triaged
Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: Triaged → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in udd:
status: Confirmed → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
milestone: none → 2.8.2
Changed in udd:
status: In Progress → Fix Released
Changed in bzr-builddeb:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers