DEP3-style patch formatting

Bug #460576 reported by Jelmer Vernooij
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bzr-builddeb
Wishlist
Jelmer Vernooij

Bug Description

  affects bzr-builddeb

It would be nice if bzr-builddeb had some way (extra command, "bzr diff"
format?) to generate DEP3-style patches.

--
Jelmer Vernooij <email address hidden> - http://samba.org/~jelmer/
Jabber: <email address hidden>

Related branches

Revision history for this message
Robert Collins (lifeless) wrote :

How would this be used? I mean, builddeb is all about not needing to drop to patches isn't it?

Changed in bzr-builddeb:
status: New → Incomplete
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Actually there is usecase for this. You branch off upstream tag or use current working directory do edit/testbuilds to fix a bug and then you need to save this diff as patch in debian/patches. And debian/ubuntu standertised on DEP-3 such that it is easier to share patches between upstream & other distros. Info such as author, date, urls for commit and bug fixes can be easily retrieved from bzr. Imfo this smells like $ bzr log -p --format though. But because it is very debian packaging related thing it should live in bzr-builddeb.

Changed in bzr-builddeb:
status: Incomplete → Confirmed
Revision history for this message
Robert Collins (lifeless) wrote :

Still waiting for Jelmer - the bug filers - feedback.

Changed in bzr-builddeb:
status: Confirmed → Incomplete
Revision history for this message
Jelmer Vernooij (jelmer) wrote :

Sigh, I forgot what I meant here exactly - closing. Sorry for the overhead. I'll try to be clearer in the future so that I actually can recall what I meant myself. :-)

Changed in bzr-builddeb:
status: Incomplete → Invalid
Revision history for this message
Jelmer Vernooij (jelmer) wrote :

I remembered again what I wanted this for. I'd like to be able to e.g. say:

$ bzr dep3-patch -c 45 lp:bzr > debian/patches/04_fix_it

Where 04_fix_it would then contain the standard DEP3 header with as much information as possible already filled in and a -p1 diff. Things in the header that could be filled in beforehand: links to upstream bugs, list of authors, last updated time, etc.

Changed in bzr-builddeb:
status: Invalid → Triaged
importance: Undecided → Wishlist
Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
status: Triaged → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 2.8
Jelmer Vernooij (jelmer)
Changed in bzr-builddeb:
milestone: 2.8 → 2.7.5
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers