document-plugin.py shouldn't require plugin to be installed

Bug #742243 reported by Andrew Bennetts on 2011-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar All Docs Website
Low
Unassigned

Bug Description

“scripts/document-plugin.py FOO” finds FOO from the installed plugins. It would be nice if it could automatically fetch the latest (released?) version into its own directory and use that, rather than requiring a system or user to install and update all the plugins. The BZR_PLUGIN_PATH environment variable is probably a good mechanism to use for this.

Andrew Bennetts (spiv) wrote :

I suppose there are two parts here really. Automating the fetching, and then using the fetched version.

It's possible to do this manually via e.g. BZR_PLUGIN_PATH.

Changed in bzr-alldocs:
importance: Undecided → Low
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers