tmux: unknown option -- X

Bug #946112 reported by Paul Natsuo Kishimoto on 2012-03-04
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

Per the suggestion at http://superuser.com/questions/387256/how-do-i-reset-the-status-bar-colors-in-byobu , I run byobu-select-profile to reset the status bar colours:

$ byobu-select-profile

[press 2, Enter]
[press 1, Enter]

tmux: unknown option -- X
usage: tmux [-28lquvV] [-c shell-command] [-f file] [-L socket-name]
            [-S socket-path] [command [flags]]

…and the colours do not change. The <F5> prompt in the status line appears, but pressing F5 has no effect.

Package versions:

$ apt-cache policy byobu tmux
byobu:
  Installed: 5.15-0ubuntu1
  Candidate: 5.15-0ubuntu1
  Version table:
 *** 5.15-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
tmux:
  Installed: 1.6-1ubuntu1
  Candidate: 1.6-1ubuntu1
  Version table:
 *** 1.6-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Jackson Blommaert (ja6kson) wrote :

I want to add "me too" but I'm using a different version of tmux. My statusbar is not showing <F5> permanently since the 5.16 update.

byobu:
  Installed: 5.16-0ubuntu1~ppa5
  Candidate: 5.16-0ubuntu1~ppa5
  Version table:
 *** 5.16-0ubuntu1~ppa5 0
        500 http://ppa.launchpad.net/byobu/ppa/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
     4.37-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
tmux:
  Installed: 1.5-1
  Candidate: 1.5-1
  Version table:
 *** 1.5-1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status

Christoph Lange (allegristas) wrote :

I have the same problem with

$ byobu --version
byobu version 5.18
tmux 1.6

from the Gentoo ebuilds running in Konsole 2.8.4 (KDE 4.8.4). There are actually many more Byobu commands that try to call tmux -X, e.g.

$ byobu-quiet --undo
tmux: unknown option -- X
usage: tmux [-28lquvV] [-c shell-command] [-f file] [-L socket-name]
            [-S socket-path] [command [flags]]

Any code like $BYOBU_BACKEND -X won't work in tmux, at least not in version 1.6.

Here are the other occurrences of such code:
$ fgrep -- "BYOBU_BACKEND -X" `qlist byobu`
/usr/lib64/byobu/date: [ "$bd" = "0320" ] && msg="$(printf "%s" SGFwcHkgQmlydGhkYXkgU2NyZWVuIC0tIGh0dHA6Ly9iaXQubHkvc2NyZWVuLWJkYXkK | base64 -di)" && $BYOBU_BACKEND -X -S "byobu" at "*" echo "[$msg]"
/usr/bin/byobu-ctrl-a: $BYOBU_BACKEND -X at 0 source "$BYOBU_CONFIG_DIR/profile"
/usr/bin/byobu-ctrl-a: $BYOBU_BACKEND -X at 0 source "$BYOBU_CONFIG_DIR/profile"
/usr/bin/byobu-disable: $BYOBU_BACKEND -X at 0 quit
/usr/bin/byobu-quiet:$BYOBU_BACKEND -X at 0 source "$BYOBU_CONFIG_DIR/profile"
/usr/bin/byobu-select-profile: $BYOBU_BACKEND -X at 0 source "$BYOBU_CONFIG_DIR/profile"

Dustin Kirkland  (kirkland) wrote :

Confirmed. Looking...

Changed in byobu:
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Committed revision 2021.

Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers