Latest tmux being required should be indicated in the readme (or elsewhere)

Bug #911825 reported by KTamas on 2012-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Wishlist
Unassigned

Bug Description

So I was on Debian 6 and I was tearing my hair out because of the following issue:

(0. ssh into the remote server running debian 6)
1. run `byobu` (with tmux as the engine)
2. close terminal window
3. open another terminal window
(4. ssh into the remote server running debian 6)
5. run `byobu`

Instead of reattaching, you get the error "no sessions". Upon further debugging, I've found that the command that fails is in `byobu-select-session`, line 103:

`os.execvp("tmux", ["", "-2", "attach"])`

Now, running `tmux -2 attach` from the terminal by hand worked just fine, but it failed if ran from `os.execvp`.

Debian 6 comes with python 2.6 and tmux 1.3. I've tried updating python to 2.7, but the issue remained; then as a last resort, I've downloaded and compiled the latest tmux version from source, and voilá, byobu suddenly worked.

Unfortunately the readme only says

"Note that you will need to have a few dependencies installed:
 * screen and/or tmux"

I think it should be expanded to indicate the minimal screen and/or tmux versions, whatever that may be. Or add a warning to always use the latest screen/tmux, or something like that. Might be common sense but since I was running on the latest stable debian I foolishly assumed it'd just work.

Dustin Kirkland  (kirkland) wrote :

The debian/control file in the packaging shows:

Depends: ${misc:Depends}, debconf (>= 0.5) | debconf-2.0, gettext-base, python, python-newt (>= 0.52.2-11), tmux (>= 1.5)
Recommends: screen

Thus, if you install from the package archive, Debian's dependency resolution will solve it for you. I'll add a note to the readme as you suggest, though.

Changed in byobu:
importance: Undecided → Wishlist
status: New → In Progress
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers