custom-installed byobu does not find default-installed screen, tries to start tmux instead

Bug #911149 reported by quazgar on 2012-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Medium
Unassigned

Bug Description

byobu version: 5.1

When installing byobu to a custom PREFIX, it fails to recognize that there is screen installed on the machine, but not tmux. This seems to lead to setting the backend to tmux, which results in a failure to start:

line 155: exec: tmux: not found

Also changing $PREFIX/etc/byobu/backend does not seem to change anything, this file reads now

BYOBU_BACKEND="screen"

attilaolah (attilaolah) wrote :

This is also the case with version 5.0 from Portage, on Gentoo.

summary: - custom-installed byobu does not find default-installed screenn, tries to
+ custom-installed byobu does not find default-installed screen, tries to
start tmux instead
Changed in byobu:
importance: Undecided → Medium
status: New → In Progress
Dustin Kirkland  (kirkland) wrote :

Thanks for the report. I just committed a fix to the automatic detection of the backend.

As for changing your setting, use the byobu-select-backend utility. This will write the file ~/.byobu/backend to your local configuration.

Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers