Byobu on Hardy should not depend on tmux

Bug #910187 reported by Jorge E. Gómez on 2011-12-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
byobu
Low
Unassigned

Bug Description

Byobu 5.1 introduced a hard dependency on the tmux package, which is not available on main or universe (or even multiverse?) on versions prior to Lucid.

Could this dependency be changed to a suggestion, or a multiple-choice dependency on either screen or tmux?

Changed in byobu:
importance: Undecided → Low
status: New → Confirmed
Changed in byobu:
status: Confirmed → In Progress
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released

The last version of byobu is still having this problem

root@server:~# byobu
exec: 162: tmux: not found

root@server:~# apt-cache policy byobu
byobu:
  Installed: 5.2-0ubuntu1~ppa1
  Candidate: 5.2-0ubuntu1~ppa1
  Version table:
 *** 5.2-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net hardy/main Packages
        100 /var/lib/dpkg/status

root@server:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.4 LTS"

root@server:~# uname -r
2.6.24-28-server

Forgot to add:

root@server:~# apt-get install tmux
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package tmux is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package tmux has no installation candidate

Hilario,

Can you run:
 $ byobu-select-backend screen

And then try? Note that this will force byobu to use screen instead
of tmux, which is what will have to happen on hardy.

Félim Whiteley (felimwhiteley) wrote :

Hi Dustin,

I've got the same problem on a hardy box. I've tried the byobu-select-backend screen command but it gives the same error.

Byobu Version: 5.3-0ubuntu1~ppa1

Server is hardy with latest updates.

Félim Whiteley (felimwhiteley) wrote :

By same error I should clarify

"exec: 163: tmux: not found"

Thanks

Félim Whiteley (felimwhiteley) wrote :

Having looked at the /usr/bin/byobu code I realised I can trick it to work by running byobu-screen, but it doesn't start up automatically on ssh login for instance.

Sorry for the bug noise...

Dustin Kirkland  (kirkland) wrote :

Reopening...

Changed in byobu:
status: Fix Released → Confirmed
Andre (ajx) wrote :

Just wanted anybody getting the tmux error to know that Dustin's solution in comment #3 works fine. You only have to call the command once:

$ byobu-select-backend screen

From there on byobu works on Hardy even when it is autostarting on login. Thanks for the help, Dustin.

Dustin Kirkland  (kirkland) wrote :

Sure thing!

Changed in byobu:
status: Confirmed → Fix Released
Jos Schwab (anchor-man42) wrote :

Hi all, I am new to Linux but have more than 20 years on IBM Mainframes. I just want to say that I like BYOBU for ease of navigation between many screens I have open on multiple servers simultaneously. I have had BYOBU installed on Fedora 16 with screen. Worked great out of the box. I then installed BYOBU on Centos EL6 using YUM along with screen; but did not install tmux. I found Dustin's article about performing a 'export BYOBU_PREFIX'. That resolved some issues with my Centos. But now have the problem described here in buy #910187 'exec 163: tmux not found' on Centos. Running 'byobu-select-backend screen' did nothing. Actually, I don't believe it even executed after the prompt. But, importantly, I did run byobu-screen as Felim suggested in comment #6. That brought up BYOBU and screen. Then I hit F9 for the menu; selected 'Byobu currently does not launch at login (toggle on)', and it works fine so far without tmux. Have not rebooted yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers