prefix cpu_freq < 1Ghz with leading zero

Bug #909325 reported by Erik Quaeghebeur on 2011-12-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Wishlist
Dustin Kirkland 

Bug Description

In byobu<=5.0, cpu_freq smaller than 1Ghz are listed without a leading zero. With current frequency-scaling processors, there is often a quick succession of 2.7Ghz -> 1.0Ghz -> .8Ghz, where the last step introduces a movement of indicators to the left of cpu_freq. Therefore a feature request: add a leading zero to frequencies smaller than 1Ghz.

Dustin Kirkland  (kirkland) wrote :

Thanks for the report.

So that was deliberate, in the interest of saving a character on the status line.

I suppose one character here won't kill us ;-)

Changed in byobu:
status: New → Incomplete
importance: Undecided → Wishlist
status: Incomplete → In Progress
Dustin Kirkland  (kirkland) wrote :

This would need to be fixed in the fpdiv function in /usr/lib/byobu/include/shutil.

Scott, can you take a look at this?

Changed in byobu:
assignee: nobody → Scott Moser (smoser)
status: In Progress → Triaged
Dustin Kirkland  (kirkland) wrote :

maybe:

_RET=${whole:-0}${part:+.${part}}

Changed in byobu:
status: Triaged → Fix Committed
assignee: Scott Moser (smoser) → Dustin Kirkland (kirkland)
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers