byobu: bogus installation because of prefix

Bug #897473 reported by Damien Clauzel on 2011-11-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
byobu
Low
Unassigned
byobu (Ubuntu)
Low
Unassigned

Bug Description

On MacOS, byobu v4.51 fails to run where v4.41 is running fine.

With both version, the installation procedure was:

$ ./configure --prefix $HOME
$ make
$ make install

v4.51 fails to run, saying: « /Users/dClauzel/bin/byobu: line 41: /usr/lib/byobu/include/common: No such file or directory ».

Looks like the prefix path (/Users/dClauzel) is ignored and some default is used instead.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in byobu (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2011-12-07
affects: ubuntu → byobu (Ubuntu)
Dustin Kirkland  (kirkland) wrote :

Howdy,

Have a look at the README file. I think you've missed a step at the end:

      ./configure --prefix="$HOME/byobu"
      make
      make install
      echo "export BYOBU_PREFIX=$HOME/byobu" >> $HOME/.bashrc
      echo "export PATH=$BYOBU_PREFIX/bin:$PATH" >> $HOME/.bashrc
      . $HOME/.bashrc
      byobu

I think this is probably just a documentation issue...

Changed in byobu:
importance: Undecided → Low
Changed in byobu (Ubuntu):
importance: Undecided → Low
Changed in byobu:
status: New → Invalid
Changed in byobu (Ubuntu):
status: New → Invalid

Le 8 déc. 2011 à 14:46, Dustin Kirkland a écrit :

> ./configure --prefix="$HOME/byobu"
> make
> make install
> echo "export BYOBU_PREFIX=$HOME/byobu" >> $HOME/.bashrc
> echo "export PATH=$BYOBU_PREFIX/bin:$PATH" >> $HOME/.bashrc
> . $HOME/.bashrc
> byobu
No need for this, as the script is already present in $PATH.

But for being sure I tried it; didn't help. Anyway, this approach is not standard so it should be avoided.

Regards,
 Damien CLauzel

--
Save the seals, save the world

Changed in byobu:
status: Invalid → In Progress
Changed in byobu (Ubuntu):
status: Invalid → In Progress
Dustin Kirkland  (kirkland) wrote :

Committed revision 1802.

Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 4.53-0ubuntu1

---------------
byobu (4.53-0ubuntu1) precise; urgency=low

  [ Dustin Kirkland ]
  * usr/share/byobu/profiles/common: LP: #900812
    - start screen with at least a 1 second message wait
  * usr/bin/byobu, usr/bin/byobu-ctrl-a, usr/bin/byobu-disable,
    usr/bin/byobu-enable, usr/bin/byobu-export, usr/bin/byobu-janitor,
    usr/bin/byobu-launch, usr/bin/byobu-launcher, usr/bin/byobu-
    launcher-install, usr/bin/byobu-launcher-uninstall, usr/bin/byobu-
    quiet, usr/bin/byobu-reconnect-sockets, usr/bin/byobu-select-
    backend, usr/bin/byobu-select-profile, usr/bin/byobu-shell,
    usr/bin/byobu-silent, usr/bin/byobu-status, usr/bin/byobu-status-
    detail, usr/bin/byobu-ugraph, usr/bin/byobu-ulevel,
    usr/lib/byobu/include/dirs, usr/share/byobu/profiles/byoburc:
    - big changeset to solve a few bugs, LP: #897473, #861291, #897048
    - take over ~/.byoburc, and use it for storing global byobu shell
      configuration, namely BYOBU_PREFIX when necessary
      + note that some users might have previously used ~/.byoburc to
        store byobu-only screen configuration
      + these users should now use ~/.byobu/.screenrc instead (also
        because byobu now supports both screen and tmux)
    - on first run, if byobu is running outside of its normal location
      in /usr/bin/byobu, it will automatically detect and append the
      correct BYOBU_PREFIX value and store it in ~/.byoburc
    - ~/.byoburc is now read by all usr/bin/* in order to find the
      correct prefix
  * usr/lib/byobu/include/dirs: LP: #780081
    - use ~/.local/share/byobu as BYOBU_CONFIG_DIR, if it happens to exist
  * usr/lib/byobu/include/dirs: LP: #899271
    - allow explicit BYOBU_CONFIG_DIR selection in ~/.byoburc
  * usr/lib/byobu/users, usr/share/byobu/status/statusrc,
    usr/share/man/man1/byobu.1: LP: #900663
    - add support for a USERS_DISTINCT=1 status configuration setting
      to count the number of distinct users, rather than open ssh sessions

  [ Andrew McCarthy ]
  * usr/bin/byobu-status: LP: #898801
    - fix status detailing, skip include, as it's a directory
 -- Dustin Kirkland <email address hidden> Mon, 05 Dec 2011 08:59:08 -0600

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Changed in byobu:
status: Fix Committed → Fix Released
Damien Clauzel (damien-clauzel) wrote :

The problem is fixed for me with byobu v4.54. Many thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers