Byobu does not run with limited privileges (CentOS 5)

Bug #897048 reported by Brett Alton on 2011-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Medium
Unassigned

Bug Description

I have a server with WebFaction (http://webfaction.com), a host that runs shared servers, but allows you to compile your own applications. I've had to install git this way as an example.

I ran through your README and was unsuccessful in getting byobu 4.51 to run. These are the steps I ran:

wget http://launchpad.net/byobu/trunk/4.51/+download/byobu_4.51.orig.tar.gz
tar -xvzf byobu_4.51.orig.tar.gz
cd byobu-4.51/
./configure --prefix="$HOME/byobu"
make
make install
echo "export BYOBU_PREFIX=$HOME/byobu" >> $HOME/.bashrc

And then it didn't work when I ran: byobu/bin/byobu (unfortunately I can't remember the error).

So I tried logging out and logging back in thinking it had something to with $HOME/.bashrc and this is what now occurs:

$ byobu/bin/byobu
byobu/bin/byobu: line 67: byobu-janitor: command not found

$ byobu/bin/byobu-janitor

$ byobu/bin/byobu
byobu/bin/byobu: line 67: byobu-janitor: command not found

Dustin Kirkland  (kirkland) wrote :

Howdy Brett, I reworked this in byobu-4.53, which I'm about to release. Could you please re-test that version? I think this should be fixed along with the fixes for Bug #897473 and Bug #861291.

Changed in byobu:
status: New → Fix Committed
importance: Undecided → Medium
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers