screen command 'shelltitle' causes byobu/screen session to hang

Bug #882067 reported by calimocho on 2011-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Medium
Unassigned

Bug Description

Start byobu
Use the shelltitle command, e.g.
  ^A :shelltitle 'hello'
Screen session stops responding to input and display is no longer updated.
It is possible to connect to the same session from another terminal.

calimocho (d-martinez7) wrote :

Sorry for lack of detail -
Issue occurs in byobu version 4.37, but not in 3.33. Not sure about other versions.
Both above versions were tested with Screen version 4.00.03jw4 (FAU) 2-May-06

Dustin Kirkland  (kirkland) wrote :

Thanks for the report. I have confirmed this issue. Looking into it now...

Changed in byobu:
status: New → Confirmed
importance: Undecided → Medium
Dustin Kirkland  (kirkland) wrote :

Ah, okay. So this issue happens if you haven't chosen your ctrl-a behavior.

Try this... Press ctrl-a, and select your ctrl-a behavior. And then set your shelltitle. Looks like that's working for me.

Dustin Kirkland  (kirkland) wrote :

Not sure about the fix. Will look into it.

Changed in byobu:
status: Confirmed → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers