byobu overwrites symlinked .bash_profile

Bug #861534 reported by nnutter on 2011-09-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 
byobu (Ubuntu)
Low
Dustin Kirkland 

Bug Description

To reproduce:
1) make .bash_profile a symlink to another file
2) launch byobu and bring up menu (F9)
3) select "Byobu currently launches at login (toggle on)"

This causes byobu to, presumably, cat together the originally .bash_profile and a new line and overwrites the existing file. This should probably instead readlink .bash_profile if it is a symlink and use the target file.

nnutter (nnutter) wrote :

Ubuntu: 2.6.32-31-generic #61-Ubuntu SMP Fri Apr 8 18:25:51 UTC 2011 x86_64 GNU/Linux
byobu: 2.68-0ubuntu1.1

Changed in byobu:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Dustin Kirkland (kirkland)
Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 4.43-0ubuntu1

---------------
byobu (4.43-0ubuntu1) precise; urgency=low

  [ Dustin Kirkland ]
  * usr/bin/byobu, usr/lib/byobu/ip_address, usr/share/man/man1/byobu.1:
    - support IP_EXTERNAL fetching, LP: #873736
    - put ip address in the terminal title bar, since we ran out of room
      for it in tmux
  * usr/bin/byobu-select-session: LP: #869390
    - fix select session to obey BYOBU_BACKEND
  * configure.ac, usr/bin/Makefile.am: LP: #869377
    - provide byobu-tmux and byobu-screen symlinks
  * configure.ac, README: LP: #861291
    - configure should not change files under vcs control
    - compiling users need to ensure that BYOBU_PREFIX is set in
      their environment
  * usr/bin/byobu-launcher-install, usr/bin/byobu-launcher-uninstall:
    - LP: #861534
    - ensure launcher command removed from each file before installing
  * usr/lib/byobu/.dirs:
    - use /dev/shm for cache, LP: #872551, #869279
    - search and use a shared dir when possible
  * usr/lib/byobu/battery: LP: #851100
    - rework the battery logic to use /sys instead of /proc
  * usr/share/man/man1/byobu.1: LP: #713879
    - note too many files open ulimit error in documentation

  [ Daniel Hahler ]
  * usr/bin/byobu, usr/bin/byobu-launcher-install, usr/bin/byobu-
    launcher-uninstall: Use BYOBU_PREFIX explicitly, LP: #861302
  * debian/rules, README: LP: #854868
    - refactor autoconf into debian/rules

  [Scott Moser]
  * usr/lib/byobu/.shutil: fix rounding error in fpdiv, LP: #869282
 -- Dustin Kirkland <email address hidden> Fri, 21 Oct 2011 13:43:57 -0500

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers