Trying to start byobu 3.3 in OS Z Snow Leopard fails with a sed error invalid option -m

Bug #625387 reported by Matt Sellars on 2010-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Medium
Unassigned

Bug Description

After installing byobu 3.3 on Snow Leopard I tried to start byobu and got the error sed invalid option -m. I traced it down to byobu-janitor and fixed it by adding e to the all the sed options so they read:

sed -ie ...

Related branches

Matt Sellars (matt-sellars) wrote :

I should clarify by fix it with adding the 'e' option - it starts. I still see other issues but I'm not sure if that is due to my byobu config or not yet.

Dustin Kirkland  (kirkland) wrote :

Great, thanks, I made this a comprehensive change. Fix committed.

Changed in byobu:
status: New → Triaged
importance: Undecided → Medium
Goolic (goolic) wrote :

I can confirm this also resolves a "sed: 1: "/Volumes/Dados/Users/go ...": extra characters at the end of D command" problem

Changed in byobu:
status: Triaged → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers