Activity log for bug #580384

Date Who What changed Old value New value Message
2010-05-14 08:31:29 Mark Schouten bug added bug
2010-05-14 08:31:29 Mark Schouten attachment added Patch to check if the dir we try to touch a file in actually exists http://launchpadlibrarian.net/48433339/byobu-launcher-uninstall.testifdirexists.patch
2010-05-15 19:59:53 Dustin Kirkland  byobu: status New Fix Committed
2010-05-15 19:59:55 Dustin Kirkland  byobu: importance Undecided Low
2010-05-15 19:59:57 Dustin Kirkland  byobu: assignee Dustin Kirkland (kirkland)
2010-05-15 20:00:02 Dustin Kirkland  bug task added byobu (Ubuntu)
2010-05-15 20:00:11 Dustin Kirkland  byobu (Ubuntu): status New Fix Committed
2010-05-15 20:00:14 Dustin Kirkland  byobu (Ubuntu): importance Undecided Low
2010-05-15 20:45:25 Launchpad Janitor branch linked lp:byobu
2010-05-15 21:00:10 Launchpad Janitor byobu (Ubuntu): status Fix Committed Fix Released
2010-05-15 21:13:15 Launchpad Janitor branch linked lp:ubuntu/byobu
2010-05-21 14:40:25 Dustin Kirkland  byobu: status Fix Committed Fix Released
2010-06-13 17:08:29 Dustin Kirkland  nominated for series Ubuntu Lucid
2010-06-13 17:08:29 Dustin Kirkland  bug task added byobu (Ubuntu Lucid)
2010-06-13 17:08:58 Dustin Kirkland  byobu (Ubuntu Lucid): status New In Progress
2010-06-13 17:09:00 Dustin Kirkland  byobu (Ubuntu Lucid): importance Undecided Low
2010-06-13 17:09:03 Dustin Kirkland  byobu (Ubuntu Lucid): assignee Dustin Kirkland (kirkland)
2010-06-13 17:10:37 Dustin Kirkland  byobu (Ubuntu Lucid): milestone lucid-updates
2010-06-13 17:18:33 Dustin Kirkland  description When running byobu-launcher-install on a new machine (which hasn't run byobu yet), it fails with the following message: root@host01:~# byobu-launcher-install touch: cannot touch `/root/.byobu/disable-autolaunch': No such file or directory If you start buyobu first, quit and than run byobu-launcher-install, it works fine. The issue seems to be in byobu-launcher-uninstall. Please find patch attached. When running byobu-launcher-install on a new machine (which hasn't run byobu yet), it fails with the following message: root@host01:~# byobu-launcher-install touch: cannot touch `/root/.byobu/disable-autolaunch': No such file or directory If you start buyobu first, quit and than run byobu-launcher-install, it works fine. The issue seems to be in byobu-launcher-uninstall. Please find patch attached. ==== SRU * IMPACT: affects users who run byobu-launcher-install before ever having run byobu (mostly affects ubuntu vm appliance makers) * HOW FIXED: this is trivially fixed with a very safe mkdir -p * TEST CASE: install byobu; make sure that ~/.byobu does not exist; try running byobu-launcher-install; boom; install new package, try same thing, works better * REGRESSION POTENTIAL: none ===
2010-06-13 17:19:19 Dustin Kirkland  attachment added out http://launchpadlibrarian.net/50275817/out
2010-06-13 17:35:38 Dustin Kirkland  byobu (Ubuntu Lucid): status In Progress Fix Committed
2010-06-16 10:05:45 Colin Watson bug added subscriber Ubuntu Stable Release Updates Team
2010-06-16 10:05:49 Colin Watson bug added subscriber SRU Verification
2010-06-16 10:05:55 Colin Watson tags verification-needed
2010-06-16 15:43:03 Martin Pitt tags verification-needed verification-done
2010-06-24 13:47:24 Launchpad Janitor byobu (Ubuntu Lucid): status Fix Committed Fix Released
2010-08-24 15:11:39 Launchpad Janitor branch linked lp:ubuntu/lucid-proposed/byobu
2011-09-19 21:20:05 Ubuntu Foundations Team Bug Bot tags verification-done testcase verification-done