Byobu can not handle single hidden sessions

Bug #1548384 reported by Alexander Fougner on 2016-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Medium
Dustin Kirkland 

Bug Description

VERSION=5.102

When a single hidden session for tmux ("_mysession") is created, the next time we execute "byobu" the bash byobu script end up dispatching the call to select-session.py, which in turn calls byobu without arguments.

This results in the following arguments sent to tmux:
exec tmux -u -2 -f /usr/share/byobu/profiles/tmuxrc

Steps to reproduce:
1. Create a hidden session, byobu new-session -s _rtorrent
2. Execute "byobu"

Results in:
ambiguous command: , could be: <long list of possible commands>

Preferably byobu should be able to handle such a case, ignoring the hidden session and successfully create a new session.

Related branches

description: updated
Dustin Kirkland  (kirkland) wrote :

Hmm, I'm not able to reproduce this problem...

Could you record a screencast?

Thanks!

Changed in byobu:
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland  (kirkland)
status: New → In Progress
status: In Progress → Incomplete
Alexander Fougner (fougner) wrote :

Hi Dustin,

Here's a video reproducing it on a Xenial Gnome live instance. It's just a few days old.
https://dl.dropboxusercontent.com/u/103754/Screencast%20from%2002-29-2016%2007%3A48%3A28%20AM.webm

Changed in byobu:
status: Incomplete → New
Dustin Kirkland  (kirkland) wrote :

bzr commit -m '* usr/lib/byobu/include/select-session.py: LP: #1548384
  - when selecting a session, if only empty sessions exist, then create
    a new one; the bug was that tmux considers a null string argument
    still an argument' --fixes 'lp:1548384'
Committing to: /srv/media/src/byobu/byobu/
modified debian/changelog
modified usr/lib/byobu/include/select-session.py
Committed revision 2527.

Changed in byobu:
status: New → Fix Committed
Dustin Kirkland  (kirkland) wrote :

Thanks for following up. I have committed a fix for the problem, albeit different from your proposed merge. You'll see it released in byobu 5.113. Cheers!

Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers