byobu doesn't autostart with TERM=screen-256color

Bug #1338260 reported by FriedricH on 2014-07-06
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

Byobu start's only with TERM variable set to xterm-256color, but this setting isn't recommended by tmux - I have black artifacts in mc viewer and strange nano behavior. But if I set TERM to screen-256color it starts only by hand with byobu command.

Ubuntu 14.04, tmux 1.8, byobu 5.74

FriedricH (rkurbatov) on 2014-07-06
description: updated
Dustin Kirkland  (kirkland) wrote :

Hi there, thanks for the report.

Can you please post some screen shots, and clear, step-by-step reproduce instructions?

Thanks!

Changed in byobu:
assignee: nobody → Dustin Kirkland  (kirkland)
importance: Undecided → Low
status: New → Incomplete
FriedricH (rkurbatov) wrote :

I have two remote servers with Ubuntu 12.04 and Ubuntu 14.04 (fresh install) on them. I've installed byobu on both and chose tmux as console manager.

If I set TERM=screen or TERM=xterm or TERM=xterm-256color byobu starts automatically after SSH login to both servers.

But if I use TERM=screen-256color (which is only usable 256 color term without console artifacts on tmux) byobu doesn't start after SSH login, so I need to start it manually with byobu command.

I use PuTTY for ssh-connections but this problem exists even when I connect from linux PC with gnome-terminal.

Chris Johnston (cjohnston) wrote :

I can confirm the same behavior. Setting TERM to screen-256color and byobu will not start after ssh login like it is supposed to.

Changed in byobu:
status: Incomplete → Confirmed
Chris Johnston (cjohnston) wrote :

I just tested on precise and it happens there:

Installed: 5.17-0ubuntu1

FriedricH (rkurbatov) wrote :

I compared env with TERM=xterm when byobu is running and TERM=screen-256color when byobu isn't running. The difference is

BYOBU_TTY=/dev/pts/2
BYOBU_CHARMAP=UTF-8

which are set in first case and absent in second. But setting it manually in .profile still not autostart BYOBU.

Something is wrong in starting scripts as I understand.

Olivier Bilodeau (plaxx) wrote :

Same problem after I upgraded to 5.90.

This TERM variable really confuses me. I originally fiddled with it until things started to be pretty (using byobu/tmux, solarized terminator as my terminal and solarized vim).

I found out that screen-256color-bce worked best. Now, with this bug, I tried setting it to xterm-256color: the bug is gone and colors are still pretty... Oh well.

solarized http://ethanschoonover.com/solarized

Dustin Kirkland  (kirkland) wrote :

So this is a safeguard, in /usr/bin/byobu-launcher, to prevent you from crashing your system.

For instance, if you're inside of a byobu shell on a system that's set to autolaunch byobu, and then you ssh into localhost, we need to make sure that you don't launch byobu inside of byobu.

Changed in byobu:
status: Confirmed → In Progress
Changed in byobu:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Chris Johnston (cjohnston) wrote :

5.97 from the PPA appears to fix this for me. Thanks for your work on this Dustin!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers