Running byobu-ctrl-a fails

Bug #1313209 reported by Kevin Godby on 2014-04-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
byobu
Critical
Dustin Kirkland 
byobu (Ubuntu)
Critical
Dustin Kirkland 

Bug Description

Running byobu-ctrl-a fails due to a syntax error.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

$ byobu --version
byobu version 5.74
tmux 1.8

$ byobu-ctrl-a

Configure Byobu's ctrl-a behavior...

When you press ctrl-a in Byobu, do you want it to operate in:
    (1) Screen mode (GNU Screen's default escape sequence)
    (2) Emacs mode (go to beginning of line)

Note that:
  - F12 also operates as an escape in Byobu
  - You can press F9 and choose your escape character
  - You can run 'byobu-ctrl-a' at any time to change your selection

Select [1 or 2]: 1

/usr/bin/byobu-ctrl-a: 151: /usr/bin/byobu-ctrl-a: Syntax error: Unterminated quoted string

Changed in byobu:
importance: Undecided → Critical
status: New → In Progress
assignee: nobody → Dustin Kirkland  (kirkland)
Changed in byobu (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Dustin Kirkland  (kirkland)
Dustin Kirkland  (kirkland) wrote :

bzr commit -m '* usr/bin/byobu-ctrl-a.in: LP: #1313209
  - fix syntax error, remove unnecessary bindkey line' --fixes 'lp:1313209'
Committing to: /local/media/src/byobu/byobu/
modified debian/changelog
modified usr/bin/byobu-ctrl-a.in
Committed revision 2344.

Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.79-0ubuntu1

---------------
byobu (5.79-0ubuntu1) utopic; urgency=medium

  [ Dustin Kirkland ]
  * usr/bin/byobu-ctrl-a.in: LP: #1313209
    - fix syntax error, remove unnecessary bindkey line
    - also fixes LP: #814172
  * usr/share/byobu/profiles/tmuxrc:
    - tmux windows still aren't working right; disable for now

  [ Kosuke Asami ]
  * usr/lib/byobu/include/config.py.in: LP: #1303218
 -- Dustin Kirkland <email address hidden> Wed, 23 Apr 2014 18:24:26 -0500

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Dave Chiluk (chiluk) wrote :

The trusty fix for this is still sitting in trusty-proposed. Can this be released to updates?

Dustin Kirkland  (kirkland) wrote :

Hey Dave,

Yes, it should. I just pushed a further update.

Also, I'm going to mark this bug a dupe of Bug #1274720

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers