new windows doesn't go to PWD

Bug #1277734 reported by seilgu on 2014-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

In tmux if I use Ctrl+b c to create a window, the new window starts at the current working directory.
But if I use byobu and press F2 to create a window, it always starts at the directory when byobu is first launched.
For example if I run byobu at the root directory /, then in byobu i cd to /home,
and then I press F2 to create another window, the starting directory for that windows would be in the root directory / .

But in tmux it works correctly.

Dustin Kirkland  (kirkland) wrote :

I'm unable to reproduce this with:

byobu version 5.73
tmux 1.8

What version of byobu/tmux are you seeing this problem in?

Changed in byobu:
importance: Undecided → Low
status: New → Fix Released
status: Fix Released → Incomplete
Chris Johnston (cjohnston) wrote :

I have this issue with both Ctrl+a c and with F2..

byobu:
  Installed: 5.81-0ubuntu1~ubuntu14.04.1~ppa1
  Candidate: 5.81-0ubuntu1~ubuntu14.04.1~ppa1
tmux:
  Installed: 1.9-5~ubuntu14.04.1~ppa1
  Candidate: 1.9-5~ubuntu14.04.1~ppa1

Changed in byobu:
status: Incomplete → Confirmed
Dustin Kirkland  (kirkland) wrote :

Hmm, I'm still unable to reproduce this issue.

Can you please rm -rf ~/.byobu, or at least move it aside, and launch a fresh one? Perhaps there's an old configuration lingering in there...

Changed in byobu:
status: Confirmed → Incomplete
assignee: nobody → Dustin Kirkland  (kirkland)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers