Byobu sources $BYOBU_CONFIG_DIR/.tmux.conf twice

Bug #1273685 reported by Ankur Sinha on 2014-01-28
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 
byobu (Fedora)
Fix Released
Undecided
byobu (Ubuntu)
Low
Dustin Kirkland 

Bug Description

Description of problem:
Byobu appears to source $BYOBU_CONFIG_DIR/.tmux.conf *twice*

Version-Release number of selected component (if applicable):
byobu-5.69-2.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Write a simple .byobu/.tmux.conf file:

[asinha@ankur-laptop ~]$ cat .byobu/.tmux.conf
new-window -ad -n "ncmpcpp"
new-window -ad -n "irssi"
[asinha@ankur-laptop ~]$

2. select tmux as backend
3. run byobu

Actual results:
It starts two sessions (bug filed). The one session that does have these windows has them twice.

Expected results:
Session should only have them once

Additional info:
I dug in a little. So, byobu's command line with tmux is:

asinha 32124 1.5 0.0 22568 2076 ? Ss 00:18 0:00 tmux -2 -f /usr/share/byobu/profiles/tmuxrc new-session -n - /usr/bin/byobu-shell

Now, tmuxrc sources the following files:
source-file $HOME/.byobu/color.tmux
source-file $BYOBU_CONFIG_DIR/profile.tmux
source-file $BYOBU_CONFIG_DIR/keybindings.tmux
source-file $BYOBU_CONFIG_DIR/.tmux.conf

Note that it's already sourcing $BYOBU_CONFIG_DIR/.tmux.conf

It also sources $BYOBU_CONFIG_DIR/profile.tmux which has the one line:
source $BYOBU_PREFIX/share/byobu/profiles/tmux

This file, again sources $BYOBU_CONFIG_DIR/.tmux.conf in it's last line:
[asinha@ankur-laptop ~]$ tail -2 /usr/share/byobu/profiles/tmux
# Allow local overrides
source $BYOBU_CONFIG_DIR/.tmux.conf

I think this causes duplication of windows.

Description of problem:
Byobu appears to source $BYOBU_CONFIG_DIR/.tmux.conf *twice*

Version-Release number of selected component (if applicable):
byobu-5.69-2.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Write a simple .byobu/.tmux.conf file:

[asinha@ankur-laptop ~]$ cat .byobu/.tmux.conf
new-window -ad -n "ncmpcpp"
new-window -ad -n "irssi"
[asinha@ankur-laptop ~]$

2. select tmux as backend
3. run byobu

Actual results:
It starts two sessions (bug filed). The one session that does have these windows has them twice.

Expected results:
Session should only have them once

Additional info:
I dug in a little. So, byobu's command line with tmux is:

asinha 32124 1.5 0.0 22568 2076 ? Ss 00:18 0:00 tmux -2 -f /usr/share/byobu/profiles/tmuxrc new-session -n - /usr/bin/byobu-shell

Now, tmuxrc sources the following files:
source-file $HOME/.byobu/color.tmux
source-file $BYOBU_CONFIG_DIR/profile.tmux
source-file $BYOBU_CONFIG_DIR/keybindings.tmux
source-file $BYOBU_CONFIG_DIR/.tmux.conf

Note that it's already sourcing $BYOBU_CONFIG_DIR/.tmux.conf

It also sources $BYOBU_CONFIG_DIR/profile.tmux which has the one line:
source $BYOBU_PREFIX/share/byobu/profiles/tmux

This file, again sources $BYOBU_CONFIG_DIR/.tmux.conf in it's last line:
[asinha@ankur-laptop ~]$ tail -2 /usr/share/byobu/profiles/tmux
# Allow local overrides
source $BYOBU_CONFIG_DIR/.tmux.conf

I think this causes duplication of windows.

no longer affects: byobu (Fedora)

waiting for fix from upstream

Jan Klepek (jan-klepek-gmail) wrote :

this is patch whats going to be used by fedora to fix this bug

there is patch provided to upstream which will be part of byobu-5.73-3 later this week

byobu-5.73-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/byobu-5.73-3.fc20

byobu-5.73-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-5.73-3.el5

byobu-5.73-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/byobu-5.73-3.el6

byobu-5.73-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/byobu-5.73-3.fc19

byobu-5.73-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/byobu-5.73-4.fc19

byobu-5.73-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-5.73-4.el5

byobu-5.73-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/byobu-5.73-4.el6

byobu-5.73-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/byobu-5.73-4.fc20

Changed in byobu:
status: New → In Progress
importance: Undecided → Medium
importance: Medium → Low
assignee: nobody → Dustin Kirkland  (kirkland)
Changed in byobu (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Dustin Kirkland  (kirkland)
Dustin Kirkland  (kirkland) wrote :

Thanks, for the patch, Jan.

I'm actually going to remove it from usr/share/byobu/profiles/tmux rather than usr/share/byobu/profiles/tmuxrc.

Dustin Kirkland  (kirkland) wrote :

bzr commit -m '* usr/share/byobu/profiles/tmux: LP: #1273685
  - remove double sourcing of local .tmux.conf' --fixes 'lp:1273685'
Committing to: /home/local/media/source/byobu/byobu/
modified debian/changelog
modified usr/share/byobu/profiles/tmux
Committed revision 2294.

Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu (Ubuntu):
status: In Progress → Fix Committed

The attachment "byobu-5.73-tmuxrc_source.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

byobu-5.73-4.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

byobu-5.73-4.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Changed in byobu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package byobu - 5.74-0ubuntu1

---------------
byobu (5.74-0ubuntu1) trusty; urgency=low

  [ Dustin Kirkland ]
  * usr/lib/byobu/include/ec2instancespricing.py: LP: #1286367
    - merged in updated instance pricing script from
      https://github.com/erans/ec2instancespricing
  * usr/share/byobu/profiles/tmux: LP: #1273685
    - remove double sourcing of local .tmux.conf
  * usr/lib/byobu/battery: LP: #1270451
    - add support for yet another batter type (Android)
    - thanks to Felix Krull for the initial patch
  * usr/share/byobu/profiles/tmux: LP: #1270551
    - enable ctrl-left and ctrl-right to move among words

  [ Chris Johnston ]
  * usr/share/man/man1/byobu-layout.1: LP: #1288738
    - fix manpage typo

  [ Mike Miller ]
  * usr/lib/byobu/logo: LP: #1278006
    - fix RHEL detection for logo

  [ Daniel Hahler ]
  * usr/bin/byobu-keybindings: LP: #1258093
    - fix toggling of f-keys
  * usr/share/byobu/profiles/tmux: LP: #1258534
    - ensure that we respect BYOBU_NO_TITLE in tmux

  [ Ryo ONODERA ]
  * configure.ac, etc/profile.d/Z97-byobu.sh => etc/profile.d/Z97-
    byobu.sh.in, usr/bin/byobu-config => usr/bin/byobu-config.in,
    usr/bin/byobu-ctrl-a => usr/bin/byobu-ctrl-a.in, usr/bin/byobu-
    disable-prompt => usr/bin/byobu-disable-prompt.in, usr/bin/byobu-
    disable => usr/bin/byobu-disable.in, usr/bin/byobu-enable-prompt =>
    usr/bin/byobu-enable-prompt.in, usr/bin/byobu-enable =>
    usr/bin/byobu-enable.in, usr/bin/byobu-export => usr/bin/byobu-
    export.in, usr/bin/byobu-janitor => usr/bin/byobu-janitor.in,
    usr/bin/byobu-launcher-install => usr/bin/byobu-launcher-install.in,
    usr/bin/byobu-launcher-uninstall => usr/bin/byobu-launcher-
    uninstall.in, usr/bin/byobu-launcher => usr/bin/byobu-launcher.in,
    usr/bin/byobu-launch => usr/bin/byobu-launch.in, usr/bin/byobu-
    layout => usr/bin/byobu-layout.in, usr/bin/byobu-prompt =>
    usr/bin/byobu-prompt.in, usr/bin/byobu-quiet => usr/bin/byobu-
    quiet.in, usr/bin/byobu-reconnect-sockets => usr/bin/byobu-
    reconnect-sockets.in, usr/bin/byobu-select-backend => usr/bin/byobu-
    select-backend.in, usr/bin/byobu-select-profile => usr/bin/byobu-
    select-profile.in, usr/bin/byobu-select-session => usr/bin/byobu-
    select-session.in, usr/bin/byobu-shell => usr/bin/byobu-shell.in,
    usr/bin/byobu-silent => usr/bin/byobu-silent.in, usr/bin/byobu-
    status-detail => usr/bin/byobu-status-detail.in, usr/bin/byobu-
    status => usr/bin/byobu-status.in, usr/bin/byobu-ugraph =>
    usr/bin/byobu-ugraph.in, usr/bin/byobu-ulevel => usr/bin/byobu-
    ulevel.in, usr/bin/byobu => usr/bin/byobu.in,
    usr/lib/byobu/include/config.py =>
    usr/lib/byobu/include/config.py.in, usr/lib/byobu/include/dirs =>
    usr/lib/byobu/include/dirs.in, usr/lib/byobu/include/toggle-utf8 =>
    usr/lib/byobu/include/toggle-utf8.in, usr/share/byobu/tests/byobu-
    time-notifications => usr/share/byobu/tests/byobu-time-
    notifications.in:
    - use @prefix@ rather than hardcoding /usr, makes code
      more portable and easier to build with ./config --prefix

  [ Arminius Silvanus ]
  * usr/share/byobu/profiles/bashrc: LP: #1280550
    - te...

Read more...

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released

byobu-5.73-4.fc20 has been pushed to the Fedora 20 stable repository. If problems still persist, please make note of it in this bug report.

byobu-5.73-4.fc19 has been pushed to the Fedora 19 stable repository. If problems still persist, please make note of it in this bug report.

Changed in byobu (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.