Byobu (+screen) crashes when 1-character tall

Bug #1248901 reported by xeon927 on 2013-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

For some reason, my terminal resized to 1-character tall (I know why, that's not the issue at hand). What happens instead, is the entire screen/byobu session crashes. Screen itself doesn't do this, and byobu+tmux is perfectly fine. Seems just to be the combination of those two.

If it helps, I'm running the following versions:
Byobu: 5.21
Screen: 4.00.03jw4

Dustin Kirkland  (kirkland) wrote :

Hi there,

Thanks for the bug report. I tried a variety of terminals, and I was unable to reproduce your crash:

gnome-terminal: won't let me resize smaller than 2 rows
terminator: resizes to 1 row just fine
xterm: resizes to 1 row just fine
uxterm: resizes to 1 row just fine

What terminal are you using?

Changed in byobu:
importance: Undecided → Wishlist
status: New → Incomplete
importance: Wishlist → Low
assignee: nobody → Dustin Kirkland  (kirkland)
xeon927 (aaronmoorley192) wrote :

I've been SSHing through PuTTY

Dustin Kirkland  (kirkland) wrote :

Thanks for the report.

I just added a note to the manpage, noting the behavior. I don't have a fix per se (as Putty and Screen are not really my development target focus). Patches accepted, if you figure it out.

Thanks.

Changed in byobu:
status: Incomplete → Fix Committed
Dustin Kirkland  (kirkland) wrote :

bzr commit -m '* usr/share/man/man1/byobu.1: LP: #1248901
  - add note to manpage about putty resizing to 1-character tall and
    causing byobu-screen to crash' --fixes 'lp:1248901'
Committing to: /local/media/src/byobu/byobu/
modified debian/changelog
modified usr/share/man/man1/byobu.1
Committed revision 2319.

Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers