SSH_AUTH_SOCK doesn't use the byobu ssh-agent symlink created

Bug #1244981 reported by Brian Kearns on 2013-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

Just setup a basic byobu + tmux setup. I gather the idea of creating the ~/.byobu/.ssh-agent symlink to the "latest" SSH agent socket is so that long running shells in the session can have a constant env var that always points to the latest SSH agent socket from the most recent connection/attachment. The problem is that byobu calls tmux setenv with the "temporary" SSH_AUTH_SOCK, so shells are created pointing there and no longer work after reattachment. I've worked around this by adding a few lines to .bashrc, but I think the more correct fix would be to set SSH_AUTH_SOCK =~/.byobu/.ssh-agent, right after the symlink is created, in /usr/bin/byobu.

if [ -n "$TMUX" ] && [ -n "$SSH_AUTH_SOCK" ] && [ -n "$BYOBU_CONFIG_DIR" ]; then
    SSH_AUTH_SOCK="$BYOBU_CONFIG_DIR/.ssh-agent"
fi

Dustin Kirkland  (kirkland) wrote :

Committed revision 2235.

Changed in byobu:
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Dustin Kirkland  (kirkland)
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers