After upgrade to Raring, Byobu hangs on starting with bindkey error in f-keys.screen.disable

Bug #1195726 reported by Adrianna Pińska on 2013-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
High
Unassigned

Bug Description

I have just upgraded from Quantal to Raring. I use Byobu with the screen backend. When I start a byobu session, it's completely unresponsive and I get this error at the bottom of the screen:

/usr/share/byobu/keybindings/f-keys.screen.disable: bindkey: keybinding not found

I have tried selectively commenting out the bindkey commands at the bottom of this file, but it looks like any command with a single parameter causes the error (at least the first few do). If I comment out all the bindkey commands the error is no longer displayed, but I get an unresponsive blank window.

Screen works correctly by itself.

Related branches

Adrianna Pińska (confluence) wrote :

I forgot to add that I tried purging and reinstalling the package, and also deleting my .byobu directory. It makes no difference.

Adrianna Pińska (confluence) wrote :

I have also tried upgrading to 5.43 from the PPA -- no change.

Dustin Kirkland  (kirkland) wrote :

Thanks for the report.

This seems very odd. I'm not able to reproduce this in Ubuntu 13.04, with byobu-screen. It launches just fine, and I'm able to enable and disable the byobu-screen-f-keys just fine.

What version of screen is installed on your system? dpkg -l screen would be helpful to me. Thanks!

Changed in byobu:
importance: Undecided → High
status: New → In Progress
status: In Progress → Incomplete
Adrianna Pińska (confluence) wrote :

My screen version is 4.0.3-14ubuntu9.

I just fixed my problem, though. Running byobu as root worked correctly, so I removed my normal user's .screenrc and now everything works.

This was my .screenrc:

  shelltitle '$ |bash'

...which is half of this hack: http://dan.iel.fm/posts/screenrc-hack/

Any idea why that would break everything?

Dustin Kirkland  (kirkland) wrote :

Okay, so I've found the source of the problem... It's the -t option I'm adding in /usr/bin/byobu. If I remove those, I don't see the error/problem. I'm still looking for an appropriate fix...

Dustin Kirkland  (kirkland) wrote :

Committed revision 2147.

Changed in byobu:
status: Incomplete → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers