byobu-status: mail notification always on when the mailbox is in maildir format

Bug #1118364 reported by sutupud on 2013-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Wishlist
Unassigned

Bug Description

When the mailbox uses the maildir format, then the mail icon is always shown in the status line.

The problem is that 'test -s' always seems to return true for directories, and the script (/usr/lib/byobu/mail) doesn't handle the maildir format correctly.

I've created a patch that should correct this.
Tested with byobu 5.31-0ubuntu1

sutupud (sutupud) wrote :
description: updated
Dustin Kirkland  (kirkland) wrote :

Thanks for the patch!

Committed revision 2066.

Changed in byobu:
importance: Undecided → Wishlist
status: New → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers