Selecting text in konsole is cleared on each status interval

Bug #1073145 reported by Julian Edwards on 2012-10-30
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

If I run byobu in a konsole, selecting text with the mouse is very difficult as the selection is lost each time the session refreshes itself. Changing the status-interval to something like 10 from the default 1 clearly shows this behaviour.

Dustin Kirkland  (kirkland) wrote :

Thanks Julian.

This is a problem with some terminals (including Konsole) with tmux. Here's a discussion about it:

http://www.digipedia.pl/usenet/thread/16656/337/

Changed in byobu:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Dustin Kirkland (kirkland)
zekus (zekus-one) wrote :

This happens on iTerm2 on mac as well when I ssh into a Ubuntu server with byobu. Its not a tmux issue because if I launch pure tmux, the issue doesn't occur. It must be something related to the status bar: if I disable that and then select, I can do it fine.

zekus (zekus-one) wrote :

Actually, it is a tmux problem, sorry. increasing the tmux status-interval makes the problem less odious.

Julian Edwards (julian-edwards) wrote :

See also bug 1018538 which discusses this (but the bug is on the Ubuntu package not this upstream).

Dustin Kirkland  (kirkland) wrote :

Committed revision 1993.

Changed in byobu:
status: Confirmed → In Progress
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers