byobu hangs when ec2 metadata api is blocked

Bug #1071287 reported by Tristan Slominski on 2012-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Medium
Dustin Kirkland 

Bug Description

On EC2 Ubuntu 12.04 instance created from: ami-3d4ff254 (us-east-1, 64-bit, ebs)

~$ /usr/bin/sudo /sbin/iptables -A OUTPUT -d 169.254.169.254 -j DROP
~$ byobu

at this point, byobu will hang (sometimes it starts, sometimes it doesn't)

Tags: ec2 Edit Tag help
description: updated
Changed in byobu:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

So if, after you block the metadata service you also remove the flag ~/.byobu/.metadata_available, then it should automatically detect that metadata is no longer available.

The problem is when byobu launches once when metadata is available, and then launches or runs some other time when it's *not* available, but the cached flag still exists.

Changed in byobu:
status: Confirmed → In Progress
Dustin Kirkland  (kirkland) wrote :

Committed revision 1984

Changed in byobu:
status: In Progress → Fix Committed

Thank you sir.

Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers