sed: --follow-symlinks might not be supported

Bug #1068580 reported by Daniel Hahler on 2012-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
Low
Dustin Kirkland 

Bug Description

On CentOS 5.4 with "GNU sed version 4.1.5" the "--follow-symlink" option is not supported.

It has been added to fix bug 954031.

We could add a test for sed, but that would remove the fix on those systems.

Another solution would be to use "$BYOBU_READLINK -f" to resolve the filename used with "sed".

Changed in byobu:
importance: Undecided → Low
Dustin Kirkland  (kirkland) wrote :

I'll test for the feature, and just not add it if its not available. That does mean that CentOS 5.4 systems will be vulnerable to bug #954031. Not much more I can do about ancient versions of tools like sed. Sorry. Thanks for the bug report!

Changed in byobu:
status: New → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Committed revision 1986.

Changed in byobu:
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers