with screen back-end, using -t option hangs byobu

Bug #1031925 reported by greenmoss on 2012-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu
High
Dustin Kirkland 

Bug Description

Ubuntu Precise/12.04
Byobu package version 5.17-0ubuntu1 (eg byobu 5.17)
GNU Screen package version 4.0.3-14ubuntu8 (eg screen 4.0.3)

Set .byobu/backend to "BYOBU_BACKEND=screen"
Launch byobu with -t option: "byobu -t foo"

Result: terminal window clears, and hangs indefinitely.

Related branches

Dustin Kirkland  (kirkland) wrote :

Ugh. Yeah, confirmed.

Changed in byobu:
importance: Undecided → High
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

Aha.

Okay, so it looks like the -t option conflicts with a setting in /usr/share/byobu/profiles/common, specifically the one that unsets the title :-)

# Empty shell title by default, maximizes number of windows we can fit, F8 renames easily
#shelltitle ""

Changed in byobu:
status: Confirmed → In Progress
status: In Progress → Triaged
assignee: nobody → Dustin Kirkland (kirkland)
Changed in byobu:
status: Triaged → In Progress
status: In Progress → Fix Committed
Changed in byobu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers