Clean up ProductSeries naming properties

Bug #146302 reported by David Allouche
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Triaged
Low
Unassigned

Bug Description

The ProductSeries class (Release series in the user interface) currently provides a number of methods for name display.

displayname = name
title = "%s Series: %s" % (product.displayname, series.displayname)
bugtargetdisplayname = "%s %s" % (product.displayname, series.name)
bugtargetname = "%s/%s" % (product.name, series.name)

 * displayname is not a useful way to refer to a series, it does not provide enough context because it does not include the product name.
 * title is not generally useful because of this weird "Series: " in the middle.
 * bugtargetdisplayname is really most generally useful display name.
 * bugtargetname is the real unique name for the productseries.

The standard displayname and title properties should be modified to be more useful, and the bugtarget properties should be renamed to reflect their general usefulness.

Revision history for this message
David Allouche (ddaa) wrote :

 ddaa: actually, I'd like bugtargetname to be renamed to "unique_name" (for consistency with Branch.unique_name), and bugtargetdisplayname to replace the existing displayname.
 sabdfl: ddaa: +1 on changing ProductSeries.displayname to be more like this:
 sabdfl: firefox "trunk" series
 sabdfl: hmm.. perhaps that should be .title
 sabdfl: and displayname should just be "firefox trunk"
 ddaa: sabdfl: you mean
 ddaa: * series.title = smartquote('%s "%s" series') % (product.displayname, series.name)
 ddaa: * series.displayname = "%s %s" % (product.displayname, series.name)
 ddaa: Right?

In summary:
 * series.title = smartquote('%s "%s" series') % (product.displayname, series.name)
 * series.displayname = "%s %s" % (product.displayname, series.name)
 * series.unique_name = %s/%s" % (product.name, series.name)
 * remove bugtargetdisplayname
 * remove bugtargetname

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

ddaa asked me to record my approval of this in a comment. I approve, as long as it does not change the resulting text in bug notifications (and it seems it won't).

Revision history for this message
Björn Tillenius (bjornt) wrote :

I more or less agree with the changes proposed here. Two things to note, though:

  1) IDistroSeries should be modified in the same way.
  2) You can't just drop bugtargetname and bugtargetdisplayname;
      they are part of IBugTarget, so you'd have to make this
      change across all IBugTargets.

Since the second point is quite a big one, I'd propose keeping those attributes, delegating to unique_name and displayname.

Revision history for this message
David Allouche (ddaa) wrote :

Assigning to self. Medium importance. Targeting for 1.1.10. In progress.

Changed in launchpad:
assignee: nobody → ddaa
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
David Allouche (ddaa) wrote :

Note: I am only fixing ProductSeries. Without touching DistroSeries (which has a different set of naming attributes), and without touching IBugTarget interface (making bugtargetdisplayname and bugtargetname delegate to displayname and unique_name in ProductSeries).

Revision history for this message
David Allouche (ddaa) wrote :

Resolution currently blocked on bug 69988,

Revision history for this message
David Allouche (ddaa) wrote :

Blocker bug 69988 was targeted to 1.1.11, so retarting this to 1.1.11.

Changed in launchpad:
milestone: 1.1.10 → 1.1.11
Changed in launchpad:
milestone: 1.1.11 → 1.2.1
Changed in launchpad:
milestone: 1.2.1 → none
Curtis Hovey (sinzui)
Changed in launchpad-foundations:
status: In Progress → Triaged
affects: launchpad-foundations → launchpad-registry
Changed in launchpad-registry:
assignee: David Allouche (ddaa) → nobody
Curtis Hovey (sinzui)
tags: added: tech-debt
Changed in launchpad-registry:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.