Completely support tags

Bug #88719 reported by Daniel Holbach on 2007-02-28
6
Affects Status Importance Assigned to Milestone
Bug Helper
Wishlist
Unassigned

Bug Description

From a discussion with Alexander Sack:
<dholbach> asac: it might be easier to pass -l https://beta.launchpad.net/ubuntu/+bugs?field.tag=<your tag here> to bughelper
<dholbach> asac: (minus the beta)
<dholbach> asac: but it'd be nice to add a --tag <something> option
<asac> dholbach: ok .... and how about to negative tag search ... e.g. has tag X, but not tag Y
<asac> or even ... has no tag set, while state is "Need Info" ..
<asac> i would need such things to check our bug db integrity ... and discover "triage bugs"
<dholbach> ok - that needs work
<asac> e.g. someone from qa team messes around and sets states and tags as he likes

The changes need to go into:
 * HTML parsing (list of tags)
 * XML (add <tag> in addition to <op>)

Changed in bughelper:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Emilio Pozuelo Monfort (pochu) wrote :

the --tag option should be easy, isn't it? I also would like to see this soon :)

0.2?

Alexander Sack (asac) wrote :

this is about *complete* tag support which can be used in xml. Not about the --tag or whatever option

Emilio Pozuelo Monfort (pochu) wrote :

Well, reading the log:
<dholbach> asac: but it'd be nice to add a --tag <something> option

I think this is also about adding a --tag option (apart of what you want).
I would really love to see this option in bughelper, so if this bug report isn't about it, tell me and I'll file another one.

Best regards
Emilio

Markus Korn (thekorn) wrote :

closed that bug because:
* we have the field attribute in clue-files
* we also have the --tag-option for bug{helper|numbers}

Changed in bughelper:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers