"look to closed bug" option would be nice

Bug #81434 reported by Sebastien Bacher on 2007-01-25
4
Affects Status Importance Assigned to Milestone
Bug Helper
Wishlist
Emilio Pozuelo Monfort

Bug Description

That would be useful to find duplicates for bugs already fixed

Related branches

Daniel Holbach (dholbach) wrote :

Agreed - it'd be nice to have. Can somebody figure out the 'minimal bit' we have to add to a Launchpad bug list URL, so we get closed bugs only?

Changed in bughelper:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Emilio Pozuelo Monfort (pochu) wrote :

With closed, do you mean fixed or also rejected?

This is just for fixed bugs in ubuntu packages (where it says <package>, we should change to the package name)

https://launchpad.net/ubuntu/+source/<package>/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=Fix+Released&assignee_option=any&field.assignee=&field.owner=&field.status_upstream=&field.status_upstream-empty-marker=1&field.omit_dupes.used=&field.omit_dupes=on&field.has_patch.used=&field.tag=&search=Search

Emilio Pozuelo Monfort (pochu) wrote :

Well, you said the "minimal bit". Sorry for that link ;) I've cleaned it up:

This searches for "fix released", without dups, and orders it by importance:

https://launchpad.net/ubuntu/+source/<package>/+bugs?orderby=-importance&field.status%3Alist=Fix+Released&field.omit_dupes=on

And this one doesn't order them (but is sorter)

https://launchpad.net/ubuntu/+source/<package>/+bugs?field.status%3Alist=Fix+Released&field.omit_dupes=on

Emilio Pozuelo Monfort (pochu) wrote :

Well, they two order the bugs by importance. So they are the same, just the second looks better to use it :-)

Emilio Pozuelo Monfort (pochu) wrote :

What do you think about a "-c" "--closed" option?

Daniel Holbach (dholbach) wrote :

Sounds ok to me.

Henrik Nilsen Omma (henrik) wrote :

OK, I'm not sure I understand this :)

Do you mean that we should compare a given bug to all the fix released bugs to find similarities. That would be ery cool but would require some fancy machine learning stuff I think :)

If you have a string in a clue file you presumably already know which older bugs it was in, from when you made the clue.

Or, is this the case where you see an error string and think, 'hm, where have I seen that before' and want to grep all closed bugs for it? I guess there is a real need for that gien that Malone doesn't search comments and attachments.

Sebastien Bacher (seb128) wrote :

looking to closed bugs would be a way to list new instances of bugs which have already been fixed without having a clue file

Henrik Nilsen Omma (henrik) wrote :

OK, but that sounds highly non-trivial. You have a haystack of 2000 closed bugs and haystack of 500 open bugs; do you propose searching for patterns in the new bugs that are similar to those in the closed bugs, without giving bughelper any assistance in the form of clues? It's entirely possible but probably requires some fairly advanced text analysis routines.

Sebastien Bacher (seb128) wrote :

that looks like complicate, the request is only to have an option to look for a clue through open and closed bugs on the package specified rather than only on open bugs which is the default option

Henrik Nilsen Omma (henrik) wrote :

OK, sorry for over-complicating things :)

That sounds like a very reasonable request indeed.

Changed in bughelper:
assignee: nobody → pochu
status: Confirmed → In Progress
Emilio Pozuelo Monfort (pochu) wrote :

This patch implement this feature to bughelper.

Please, review and test! (works for me), and let me know how can it be improved (I'm a python newbie).

Markus Korn (thekorn) wrote :

I discussed with Emilio to use urllib.urlencode() avoid this long url-strings. This patch against bughelper.main r122 uses urllib.encode() and modify the "search - upstream" -parts in HTMLOperations.py.

If this works as expected adding a "search in duplicates"-option would be the next step. I think it is also nice to add these options to bugnumbers. We should also think about using urllib.urlencode in the "status"- and "importance"-filter.

Changed in bughelper:
assignee: pochu → thekorn
Emilio Pozuelo Monfort (pochu) wrote :

>I think it is also nice to add these options to bugnumbers.

This patch (which includes Markus' patch) adds also -C to bugnumbers. I've tested it and works fine.

Markus Korn (thekorn) wrote :

Thanks for your work Emilio, works fine!
I've changed the option-description from [-C] into [--closed]. We should use the long version whenever possible. In my opinion it is more userfriendly.
------------------------------------------------------------
revno: 123
committer: Markus Korn <email address hidden>
branch nick: bughelper.main
timestamp: Sun 2007-04-01 13:28:22 +0200
message:
  commit Emilio's patch to fix #81434: adding "look to closed bug" option to bugnumbers and bughelper.
------------------------------------------------------------

Changed in bughelper:
status: In Progress → Fix Committed
Changed in bughelper:
assignee: thekorn → pochu
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers