missing greeter icon for budgie-desktop

Bug #1562182 reported by fossfreedom on 2016-03-25
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
budgie-remix
Wishlist
Unassigned

Bug Description

Please can our budgie-desktop greeter icon be added to the package?

our logo is https://github.com/budgie-remix/assets/blob/master/budgie-remix-logo-large.svg

many thanks

David Mohammed - budgie-remix & budgie-desktop PPA maintainer

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity-greeter-badges (not installed)
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Budgie:GNOME
Date: Fri Mar 25 22:09:18 2016
InstallationDate: Installed on 2015-12-12 (103 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
SourcePackage: unity-greeter-badges
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

fossfreedom (fossfreedom) wrote :
Doug Torrance (profzoom) wrote :

Certainly!

However, the file you linked is in the wrong format. It should be a 22x22 PNG file, using /usr/share/unity-greeter/unknown_badge.png as a guide, with filename custom_budgie-desktop_badge.png.

If you could attach a working badge to this bug report plus license information, I'd be happy to add it to the package.

Note that I'm just the package maintainer -- I didn't create any of the other icons. I could probably fiddle around with Inkscape for some time and figure out how to do this, but perhaps someone in the Budgie team would be able to it much quicker. :)

Changed in unity-greeter-badges (Ubuntu):
status: New → Incomplete

@profzoom Thanx for offering to help us! ๐Ÿ˜Š

I've attached 3 logos in 22x22 size:

โ–ช custom_budgie-remix_badge.png : A monocolor icon with alpha transparency, coz the badges from http://www.omgubuntu.co.uk/2015/01/unity-greeter-badges-brings-missing-session-icons-ubuntu-login-screen had transparent parts. Generated from https://github.com/budgie-remix/assets/blob/master/budgie-remix-logo-large-inverted.svg

If for some reason, a transparent badge doesn't work, here u go:
โ–ช custom_budgie-remix_badge.large.png : Generated from https://github.com/budgie-remix/assets/blob/master/budgie-remix-logo-large.svg

And if that icon doesn't scale well for small sizes:
โ–ช custom_budgie-remix_badge.medium.png : Generated from https://github.com/budgie-remix/assets/blob/master/budgie-remix-logo-medium.svg

All logos here (and in our repo https://github.com/budgie-remix/assets ) are licensed under CC BY-SA 4.0 (https://github.com/budgie-remix/assets/blob/master/LICENSE ). budgie-remix Logo is designed by me (HEXcube ) and Joshua "Foggalong" Fogg. It's derived from Yuri Henrique's original Budgie logo.

Hi @profzoom

Me and @fossfreedom had a discussion about which logo to use as badge. We decided to use Yuri Henrique's original budgie logo for now and not the budgie-remix (Ubuntu Budgie) logos I submitted earlier. Coz budgie-remix's currently using most of budgie-desktop in it's vanilla form.

So, I've attached a 22x22 badge derived from Yuri Henrique's monochrome symbolic version of Budgie logo: https://www.dropbox.com/sh/tbk1qozkzdh2642/AABRxPRGxwNnwQNPdgZx1F1Aa/Budgie-Menu-Icon/view-grid-symbolic.svg.mono . You can view it on our assets repo: https://github.com/budgie-remix/assets/blob/master/Budgie/budgie-symbolic.svg

Thanks ๐Ÿ˜Œ

Changed in unity-greeter-badges (Ubuntu):
status: Incomplete → Opinion
status: Opinion → New
Doug Torrance (profzoom) wrote :

I've created a new version of the package including the Budgie Desktop badge. I installed budgie-desktop from the PPA and everything works as expected.

Note that since the Xenial release is relatively soon, I don't expect the Ubuntu devs to merge this until afterwards. So it probably will first appear in 16.10.

Doug Torrance (profzoom) on 2016-03-26
Changed in unity-greeter-badges (Ubuntu):
status: New → In Progress
assignee: nobody → Doug Torrance (profzoom)
fossfreedom (fossfreedom) wrote :

Doug - many many thanks for this. It is most appreciated :)

Doug Torrance (profzoom) wrote :

You're welcome!

Wow, that was quick! Thanks @profzoom ๐Ÿ˜Š

Changed in unity-greeter-badges (Ubuntu):
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) wrote :

Ok, this icon could be shipped in unity-greeter-badges. But then you'd have to ask your users to install this package if they want to use unity-greeter. (I think the Budgie .iso uses a different lightdm greeter.)

My opinion is that this file could be shipped in the budgie-desktop package itself. That way, there's no need to install an extra package.

This would also allow you to update the icon in the future if you ever need to, without waiting for a sponsor.

I did a search (apt-file search /usr/share/unity-greeter/ ) and saw that Unity 8 ships its own unity-greeter icon.

Doug Torrance (profzoom) wrote :

A big advantage of shipping a badge in unity-greeter-badges as opposed to budgie-desktop (or any window manager/desktop environment package) is to minimize the diff between the Debian and Ubuntu packages.

The Window Maker and Motif badges were both moved into unity-greeter-badges for this reason.

Jeremy Bicha (jbicha) wrote :

Doug, that's a good point if the Debian maintainer is unwilling to include a Ubuntu-specific icon (although it's still worth asking and not assume they wouldn't be interested).

But in this case, fossfreedom, the original bug reporter, is working to get his budgie-desktop package in Debian and be the Debian maintainer.

Jeremy Bicha (jbicha) wrote :

Because it's a big disadvantage that nothing recommends or depends on unity-greeter-badges so users have to explicitly install it which means they'd have to learn about it somewhere.

Doug, have you tried asking the unity-greeter maintainers if they'd recommend this package or just bundle the icons directly?

Doug Torrance (profzoom) wrote :

Jeremy -- I have not asked them. I just opened [1] inquiring if one of these options would be possible.

[1] https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1602098

Jeremy Bicha (jbicha) wrote :

David, seb128 recommends in bug 1602098 that the individual desktops ship their own unity-greeter icon. That way, it can be more easily updated if the branding changes.

Is your icon the upstream Budgie icon or is it something specific to the Budgie Remix? If it's upstream, I recommend moving the icon from budgie-lightdm-theme to budgie-core.

Shouldn't the icon be in /usr/share/unity-greeter ; currently budgie-lightdm-theme installs it to /usr/share/icons/hicolor/scalable/places/ ? I did not test if that worked.

Jeremy Bicha (jbicha) wrote :

Unassigning from unity-greeter

affects: unity-greeter-badges (Ubuntu) → budgie-remix
Changed in budgie-remix:
assignee: Doug Torrance (profzoom) → nobody
status: In Progress → Confirmed

Hi Jeremy,

  the icon is no longer the upstream icon (they have changed to an "irish"
ship icon) - so it is now specific to budgie-remix/ubuntu budgie (if tech
board says yes in the future).

The budgie-lightdm-theme icon installs to
/usr/share/icons/hicolor/scalable/places because we use the
lightdm-gtk-greeter - this is where this greeter picks its session icons
from.

Upstream does not include an icon for budgie-desktop (budgie-core).

If you want I can raise a bug-report on budgie-desktop and create a
specific ubuntu patch so that it installs a unity-greeter icon into
/usr/share/unity-greeter - that obviously means we no longer have the same
identical package version as debian.

Do you want me to do this?

David

On 5 August 2016 at 16:59, Jeremy Bicha <email address hidden> wrote:

> David, seb128 recommends in bug 1602098 that the individual desktops
> ship their own unity-greeter icon. That way, it can be more easily
> updated if the branding changes.
>
> Is your icon the upstream Budgie icon or is it something specific to the
> Budgie Remix? If it's upstream, I recommend moving the icon from budgie-
> lightdm-theme to budgie-core.
>
> Shouldn't the icon be in /usr/share/unity-greeter ; currently budgie-
> lightdm-theme installs it to /usr/share/icons/hicolor/scalable/places/ ?
> I did not test if that worked.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1562182
>
> Title:
> missing greeter icon for budgie-desktop
>
> Status in unity-greeter-badges package in Ubuntu:
> In Progress
>
> Bug description:
> Please can our budgie-desktop greeter icon be added to the package?
>
> our logo is https://github.com/budgie-remix/assets/blob/master/budgie-
> remix-logo-large.svg
>
> many thanks
>
> David Mohammed - budgie-remix & budgie-desktop PPA maintainer
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: unity-greeter-badges (not installed)
> ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
> Uname: Linux 4.4.0-15-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> CurrentDesktop: Budgie:GNOME
> Date: Fri Mar 25 22:09:18 2016
> InstallationDate: Installed on 2015-12-12 (103 days ago)
> InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64
> (20151209)
> SourcePackage: unity-greeter-badges
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/unity-greeter-
> badges/+bug/1562182/+subscriptions
>

Jeremy Bicha (jbicha) wrote :

The Debian package can include an icon for unity-greeter even though unity-greeter isn't in the Debian repositories.

I think it makes sense for the budgie-remix to support unity-greeter since I expect some people running Unity may want to give Budgie a try by just installing the extra packages.

It would be easiest to use the same greeter icons for Debian and Ubuntu and just wait for someone on Debian to complain if they don't like the icon.

fossfreedom (fossfreedom) wrote :

Okey dokey ... I am expecting 10.2.7 of budgie desktop to be released by
upstream hopefully this coming week. When it does I will submit to debian
with the icon patch.
I'm then off on hols to Sept so stuff will need to wait until then.

On 6 Aug 2016 16:00, "Jeremy Bicha" <email address hidden> wrote:

> The Debian package can include an icon for unity-greeter even though
> unity-greeter isn't in the Debian repositories.
>
> I think it makes sense for the budgie-remix to support unity-greeter
> since I expect some people running Unity may want to give Budgie a try
> by just installing the extra packages.
>
> It would be easiest to use the same greeter icons for Debian and Ubuntu
> and just wait for someone on Debian to complain if they don't like the
> icon.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1562182
>
> Title:
> missing greeter icon for budgie-desktop
>
> Status in budgie-remix:
> Confirmed
>
> Bug description:
> Please can our budgie-desktop greeter icon be added to the package?
>
> our logo is https://github.com/budgie-remix/assets/blob/master/budgie-
> remix-logo-large.svg
>
> many thanks
>
> David Mohammed - budgie-remix & budgie-desktop PPA maintainer
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: unity-greeter-badges (not installed)
> ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
> Uname: Linux 4.4.0-15-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> CurrentDesktop: Budgie:GNOME
> Date: Fri Mar 25 22:09:18 2016
> InstallationDate: Installed on 2015-12-12 (103 days ago)
> InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64
> (20151209)
> SourcePackage: unity-greeter-badges
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/budgie-remix/+bug/1562182/+subscriptions
>

Doug Torrance (profzoom) wrote :

Just to confirm -- we no longer want the budgie-desktop badge in unity-greeter-badges?

"๐‘ฐ๐’” ๐’š๐’๐’–๐’“ ๐’Š๐’„๐’๐’ ๐’•๐’‰๐’† ๐’–๐’‘๐’”๐’•๐’“๐’†๐’‚๐’Ž ๐‘ฉ๐’–๐’…๐’ˆ๐’Š๐’† ๐’Š๐’„๐’๐’ ๐’๐’“ ๐’Š๐’” ๐’Š๐’• ๐’”๐’๐’Ž๐’†๐’•๐’‰๐’Š๐’๐’ˆ ๐’”๐’‘๐’†๐’„๐’Š๐’‡๐’Š๐’„ ๐’•๐’ ๐’•๐’‰๐’† ๐‘ฉ๐’–๐’…๐’ˆ๐’Š๐’† ๐‘น๐’†๐’Ž๐’Š๐’™? ๐‘ฐ๐’‡ ๐’Š๐’•'๐’” ๐’–๐’‘๐’”๐’•๐’“๐’†๐’‚๐’Ž, ๐‘ฐ ๐’“๐’†๐’„๐’๐’Ž๐’Ž๐’†๐’๐’… ๐’Ž๐’๐’—๐’Š๐’๐’ˆ ๐’•๐’‰๐’† ๐’Š๐’„๐’๐’ ๐’‡๐’“๐’๐’Ž ๐’ƒ๐’–๐’…๐’ˆ๐’Š๐’†-๐’๐’Š๐’ˆ๐’‰๐’•๐’…๐’Ž-๐’•๐’‰๐’†๐’Ž๐’† ๐’•๐’ ๐’ƒ๐’–๐’…๐’ˆ๐’Š๐’†-๐’„๐’๐’“๐’†."

Jeremy, this icon is the upstream icon of Budgie desktop, and Solus and budgie-remix got separate logos different from this one.

"๐’๐ก๐จ๐ฎ๐ฅ๐๐ง'๐ญ ๐ญ๐ก๐ž ๐ข๐œ๐จ๐ง ๐›๐ž ๐ข๐ง /๐šž๐šœ๐š›/๐šœ๐š‘๐šŠ๐š›๐šŽ/๐šž๐š—๐š’๐š๐šข-๐š๐š›๐šŽ๐šŽ๐š๐šŽ๐š› ; ๐œ๐ฎ๐ซ๐ซ๐ž๐ง๐ญ๐ฅ๐ฒ ๐›๐ฎ๐๐ ๐ข๐ž-๐ฅ๐ข๐ ๐ก๐ญ๐๐ฆ-๐ญ๐ก๐ž๐ฆ๐ž ๐ข๐ง๐ฌ๐ญ๐š๐ฅ๐ฅ๐ฌ ๐ข๐ญ ๐ญ๐จ /๐šž๐šœ๐š›/๐šœ๐š‘๐šŠ๐š›๐šŽ/๐š’๐šŒ๐š˜๐š—๐šœ/๐š‘๐š’๐šŒ๐š˜๐š•๐š˜๐š›/๐šœ๐šŒ๐šŠ๐š•๐šŠ๐š‹๐š•๐šŽ/๐š™๐š•๐šŠ๐šŒ๐šŽ๐šœ/ ?"

It's the ๐‹๐ข๐ ๐ก๐ญ๐ƒ๐Œ ๐†๐“๐Š ๐†๐ซ๐ž๐ž๐ญ๐ž๐ซ's icon that's in /๐šž๐šœ๐š›/๐šœ๐š‘๐šŠ๐š›๐šŽ/๐š’๐šŒ๐š˜๐š—๐šœ/๐š‘๐š’๐šŒ๐š˜๐š•๐š˜๐š›/๐šœ๐šŒ๐šŠ๐š•๐šŠ๐š‹๐š•๐šŽ/๐š™๐š•๐šŠ๐šŒ๐šŽ๐šœ/. We already submitted Budgie icon to ๐—…๐—‚๐—€๐—๐—๐–ฝ๐—†-๐—€๐—๐—„-๐—€๐—‹๐–พ๐–พ๐—๐–พ๐—‹ package and it got accepted!๐Ÿ˜Š The package now includes budgie-desktop badge too: http://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/trunk/files/head:/data/badges/ . See bug report: #1568494

The one in /๐šž๐šœ๐š›/๐šœ๐š‘๐šŠ๐š›๐šŽ/๐šž๐š—๐š’๐š๐šข-๐š๐š›๐šŽ๐šŽ๐š๐šŽ๐š› is the badge for Unity Greeter.

If the badge is to be included as a patch in the Debian package, I've generated an ๐ฑ๐ฉ๐ฆ file from the Monochrome SVG version of Budgie logo (https://github.com/budgie-remix/assets/blob/master/Logos/Budgie/Proposed/budgie-logo-mono-light.svg ). I couldn't directly export to ๐ฑ๐ฉ๐ฆ from InkScape. So, I used GIMP to convert the exported PNG. Not sure if the quality is preserved though ๐Ÿ˜•

"๐‘ด๐’š ๐’๐’‘๐’Š๐’๐’Š๐’๐’ ๐’Š๐’” ๐’•๐’‰๐’‚๐’• ๐’•๐’‰๐’Š๐’” ๐’‡๐’Š๐’๐’† ๐’„๐’๐’–๐’๐’… ๐’ƒ๐’† ๐’”๐’‰๐’Š๐’‘๐’‘๐’†๐’… ๐’Š๐’ ๐’•๐’‰๐’† ๐’ƒ๐’–๐’…๐’ˆ๐’Š๐’†-๐’…๐’†๐’”๐’Œ๐’•๐’๐’‘ ๐’‘๐’‚๐’„๐’Œ๐’‚๐’ˆ๐’† ๐’Š๐’•๐’”๐’†๐’๐’‡. ๐‘ป๐’‰๐’‚๐’• ๐’˜๐’‚๐’š, ๐’•๐’‰๐’†๐’“๐’†'๐’” ๐’๐’ ๐’๐’†๐’†๐’… ๐’•๐’ ๐’Š๐’๐’”๐’•๐’‚๐’๐’ ๐’‚๐’ ๐’†๐’™๐’•๐’“๐’‚ ๐’‘๐’‚๐’„๐’Œ๐’‚๐’ˆ๐’†."

Jeremy,

Yeah, that'd be more end user friendly!๐Ÿ˜ƒ We were planning to bundle the upstream Budgie logo for now and when this flavor becomes official, provide Ubuntu Budgie badge (custom_ubuntu-budgie_badge.png) too. I guess that's how the official flavors does it currently for the LightDM GTK Greeter badge. However, most of 'em don't supply badges for Unity Greeter yet.๐Ÿ˜ž So, we don't really have an existing example to follow other than Unity.

fossfreedom (fossfreedom) wrote :

resolved by package 10.2.7-1 currently available in Debian Sid. Sync request made for yakkety.

Closing this.

Changed in budgie-remix:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers