mx5500 MX Revolution not recognized

Bug #246526 reported by Tom Winterhalder
4
Affects Status Importance Assigned to Milestone
btnx-config
New
Undecided
Unassigned

Bug Description

I just bought a MX5500 Keyboard including an MX Revolution Mouse.

btnx-config just recognizes a mouse, but not an MX Revolution.

On the revoco tab I can just see the following message:
An MX Revolution mouse has not been detected. revoco is disabled.

My Mouse is attached through a Logitech BT Mini-Receiver. Maybe there is just a product string to be added.

I: Bus=0003 Vendor=046d Product=c71b Version=0111
N: Name="Logitech Logitech BT Mini-Receiver"

I: Bus=0003 Vendor=046d Product=c71c Version=0111
N: Name="Logitech Logitech BT Mini-Receiver"

For additional information I attached the output of /proc/bus/input/devices

Revision history for this message
Tom Winterhalder (thwint) wrote :
Revision history for this message
Pierre Lourens (plourens3) wrote :

My MX Revolution is also not recognized, and button detection only detects the left and right mouse clicks.

Revision history for this message
Tom Winterhalder (thwint) wrote :

I downloaded the latest sources from repository and modified the source to recognize my mouse.

Baically I just added a new product with the ID of my mouse (0xC71C) to revoco.h and included the check for this product in revoco.c

Attached is the patch for these changes. (My first patch I ever made. So please inform me if I did something wrong)

Revision history for this message
Tom Winterhalder (thwint) wrote :

Seems, that there's something else not working. Even if I change the according lines in revoco.c of btnx. Revoco doesn't seem to work as expected.

Now I also downloaded the original source of revoco and compiled it, but it doesn't work. Used to work with another MX revolution (c51a).

Revision history for this message
Peter (perickson87) wrote :

The MX revolution mouse I'm using has a different ID from the revoco.c file, and what you're talking about here (it's 0xc70c).

I changed the code in revoco.c to this ID, but there is still no functionality. I'm guessing my mouse is using a newer or older protocol than what's being used in revoco.

I see this in the source:
#define MX_REVOLUTION 0xc51a // version RR41.01_B0025
#define MX_REVOLUTION2 0xc525 // version RQR02.00_B0020

From my lsusb output for my mouse, I can see the version is: RR40.07_B0092

I've been trying to reverse-engineer the different protocol from the lsusb output, but have been unsuccessful so far. I've also tried capturing the protocol in Windows while using SetPoint to switch between free-spin and click-to-click mode, also to no avail.

Is any having similar problems, or can offer any assistance to update revoco for this version of the MX revolution mouse?

I've attached my lsusb output for the mouse.

Revision history for this message
Hervé Fache (rvfh) wrote :

I had the same issue with 12.04 Beta and found a similar bug in OpenSuSE: https://bugzilla.novell.com/show_bug.cgi?id=731221
The comments allowed me to create a new file /etc/udev/rules.d/97-bluetooth-hid2hci.rules which looks like this:

# Logitech devices
KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
   RUN+="hid2hci --method=logitech-hid --devpath=%p"

The mouse now just works.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.