annotate breaks on ghost text revisions

Bug #438959 reported by Ted Gould on 2009-09-29
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
Bazaar Subversion Plugin
Undecided
Unassigned
Breezy
Low
Unassigned

Bug Description

When creating a new repository and doing annotate on the repository I get an error. Here are the steps to reproduce:

$ bzr init-repo --1.6.1-rich-root inkscape.20090928/
Shared repository with trees (format: 1.6.1-rich-root)
Location:
  shared repository: inkscape.20090928
$ cd inkscape.20090928/
$ bzr branch http://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk/ ./trunk
Branched 8673 revision(s).
$ cd trunk/
$ bzr annotate configure.ac
bzr: ERROR: Revision {('17075@79ec4920-5e0a-0410-a93a-b0c7084bcf59:inkscape%2Ftrunk:configure.ac', '<email address hidden>')} not present in "KnitVersionedFiles(_KnitGraphIndex(CombinedGraphIndex(GraphIndex('file:///home/ted/Development/inkscape.20090928/.bzr/repository/indices/988549db38edeb7e02250c822e3d1121.tix'))), <bzrlib.knit._DirectPackAccess object at 0x91f67ec>)".
$

Related branches

  affects bzr-svn
  status invalid

  affects bzr
  summary "annotate breaks on ghost text revisions"
  status triaged
  importance medium

summary: - Annotate causes error
+ annotate breaks on ghost text revisions
Changed in bzr:
importance: Undecided → Medium
status: New → Triaged
Changed in bzr-svn:
status: New → Invalid
Per Johansson (per.j) wrote :

I actually got this error on bzr diff, as I mentioned in my duplicate.

Per Johansson (per.j) wrote :

Though with a different error message I just realised:

0.367 Traceback (most recent call last):
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/commands.py", line 842, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/commands.py", line 1037, in run_bzr
    ret = run(*run_argv)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/commands.py", line 654, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/commands.py", line 1052, in ignore_pipe
    result = func(*args, **kwargs)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/builtins.py", line 1917, in run
    extra_trees=extra_trees, using=using)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 432, in show_diff_trees
    return differ.show_diff(specific_files, extra_trees)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 839, in show_diff
    return self._show_diff(specific_files, extra_trees)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 899, in _show_diff
    self._diff(file_id, oldpath, newpath, kind[0], kind[1])
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 925, in _diff
    new_path, old_kind, new_kind)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 491, in _diff_many
    new_kind)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 613, in diff
    old_date = _patch_header_date(self.old_tree, file_id, old_path)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/diff.py", line 444, in _patch_header_date
    mtime = tree.get_file_mtime(file_id, path)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/workingtree_4.py", line 1769, in get_file_mtime
    return self._repository.get_revision(last_changed_revision).timestamp
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/decorators.py", line 138, in read_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/repofmt/knitrepo.py", line 208, in get_revision
    return self.get_revision_reconcile(revision_id)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/decorators.py", line 138, in read_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/repository.py", line 1847, in get_revision_reconcile
    return self._get_revisions([revision_id])[0]
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/decorators.py", line 138, in read_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/local/python/lib/python2.6/site-packages/bzrlib/repository.py", line 1864, in _get_revisions
    raise errors.NoSuchRevision(self, revid)
NoSuchRevision: CHKInventoryRepository('file:///home/pelle/csrc/.bzr/repository/') has no revision <email address hidden>

Jelmer Vernooij (jelmer) wrote :

That is a different bug which has been fixed in bzr.dev. The bug report is bug 295611

So should this be a dupe? or closed?

-Rob

Per Johansson (per.j) wrote :

No, he was referring to me saying it applies to bzr diff as well. This bug still exists and is separate from that.

Martin Pool (mbp) on 2010-03-15
Changed in bzr:
status: Triaged → Confirmed
tags: added: annotate ghost
Philip Peitsch (philip-peitsch) wrote :

I suspect there is some relation between Bug #438959 and this one

Philip Peitsch (philip-peitsch) wrote :

Bugger.. that should have been Bug #393905

Philip Peitsch (philip-peitsch) wrote :

Here's a script that uses bzr-svn to create ghost revisions easily, reproducing this crash

Jelmer Vernooij (jelmer) wrote :

With the script you've provided and current versions of bzr-svn/bzr I can't reproduce this bug.

Jelmer Vernooij (jelmer) on 2017-06-22
Changed in brz:
status: New → Triaged
importance: Undecided → Low
Jelmer Vernooij (jelmer) on 2017-07-06
Changed in brz:
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments