NoSuchRevision error from "bzr info -v"

Bug #244291 reported by Vasil Dimov on 2008-06-30
6
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
Breezy
Medium
Unassigned

Bug Description

$ bzr info -v
Lightweight checkout (format: dirstate or dirstate-tags or pack-0.92 or rich-root or rich-root-pack)
Location:
  light checkout root: .
   checkout of branch: http://bazaar.launchpad.net/%7Emysql/mysql-server/mysql-5.1/

Format:
       control: Meta directory format 1
  working tree: Working tree format 4
        branch: Branch format 6
    repository: Packs containing knits without subtree support
bzr: ERROR: bzrlib.errors.NoSuchRevision: BzrBranch6('http://bazaar.launchpad.net/%7Emysql/mysql-server/mysql-5.1/') has no revision <email address hidden>

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/bzrlib/commands.py", line 846, in run_bzr_catch_errors
    return run_bzr(argv)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/commands.py", line 797, in run_bzr
    ret = run(*run_argv)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/commands.py", line 499, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/commands.py", line 807, in ignore_pipe
    result = func(*args, **kwargs)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/builtins.py", line 1130, in run
    verbose=noise_level, outfile=self.outf)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/info.py", line 341, in show_bzrdir_info
    outfile)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/info.py", line 369, in show_component_info
    _show_missing_revisions_working(working, outfile)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/info.py", line 227, in _show_missing_revisions_working
    tree_last_revno = branch.revision_id_to_revno(tree_last_id)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/decorators.py", line 127, in read_locked
    return unbound(self, *args, **kwargs)
  File "/usr/local/lib/python2.5/site-packages/bzrlib/branch.py", line 2105, in revision_id_to_revno
    raise errors.NoSuchRevision(self, revision_id)
NoSuchRevision: BzrBranch6('http://bazaar.launchpad.net/%7Emysql/mysql-server/mysql-5.1/') has no revision <email address hidden>

bzr 1.5 on python 2.5.2 (freebsd7)
arguments: ['/usr/local/bin/bzr', 'info', '-v']
encoding: 'US-ASCII', fsenc: 'US-ASCII', lang: None
plugins:
  launchpad /usr/local/lib/python2.5/site-packages/bzrlib/plugins/launchpad [unknown]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.
$

the tree was checked out on Jun 26 2008 at 3:30 GMT+3 like this:

bzr checkout --verbose --lightweight lp:mysql-server/5.1 /tmp/.../mysql-5.1

for a tree, checked out on Jun 29 it does not get an internal error.

I have replaced storage/innobase with a custom one, not from bzr.

Martin Pool (mbp) wrote :

I'm going to mark this as invalid because your later attempt succeeded and we can't reproduce the problem. If you can reproduce it or encounter something similar, please reopen it and ideally enclose a tarball of the affected repository or a url for it.

Changed in bzr:
status: New → Invalid
Mark Blackman (mark-exonetric) wrote :

I'm seeing the same thing on debian system. repo comes from a merge on an OS X system running bzr 1.6.

bzr: ERROR: bzrlib.errors.NoSuchRevision: BzrBranch6('file:///usr/local/bzr/fx-dev/') has no revision rlandells@richarddebian-20090421092651-yhxzpz3a62kyptm0

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 846, in run_bzr_catch_errors
    return run_bzr(argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 797, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 499, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 807, in ignore_pipe
    result = func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/builtins.py", line 1130, in run
    verbose=noise_level, outfile=self.outf)
  File "/usr/lib/python2.5/site-packages/bzrlib/info.py", line 341, in show_bzrdir_info
    outfile)
  File "/usr/lib/python2.5/site-packages/bzrlib/info.py", line 369, in show_component_info
    _show_missing_revisions_working(working, outfile)
  File "/usr/lib/python2.5/site-packages/bzrlib/info.py", line 227, in _show_missing_revisions_working
    tree_last_revno = branch.revision_id_to_revno(tree_last_id)
  File "/usr/lib/python2.5/site-packages/bzrlib/decorators.py", line 127, in read_locked
    return unbound(self, *args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/branch.py", line 2105, in revision_id_to_revno
    raise errors.NoSuchRevision(self, revision_id)
NoSuchRevision: BzrBranch6('file:///usr/local/bzr/fx-dev/') has no revision rlandells@richarddebian-20090421092651-yhxzpz3a62kyptm0

bzr 1.5 on python 2.5.2 (linux2)
arguments: ['/usr/bin/bzr', 'info', '-v', './fx-dev']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_GB.UTF-8'
plugins:
  bzrtools /usr/lib/python2.5/site-packages/bzrlib/plugins/bzrtools [1.5.0]
  launchpad /usr/lib/python2.5/site-packages/bzrlib/plugins/launchpad [unknown]

Martin Pool (mbp) wrote :

Thanks for the report Mark.

Is this reproducible for you?

What does 'bzr log -r-1 --show-ids' show you?

summary: - "bzr info -v" gets an internal error
+ NoSuchRevision error from "bzr info -v"
Changed in bzr:
importance: Undecided → Medium
status: Invalid → Confirmed
Robert Collins (lifeless) wrote :

Waiting on user feedback.

Changed in bzr:
status: Confirmed → Incomplete
Alexander Belchenko (bialix) wrote :
Download full text (3.3 KiB)

I have the same problem on my machine. `bzr info` works while `bzr info -v` does not.

C:\work\Bazaar\repos\scmproj-repo-1.9\trunk>bzr info
Repository tree (format: 1.9)
Location:
  shared repository: C:/work/Bazaar/repos/scmproj-repo-1.9
  repository branch: .

Related branches:
    push branch: bzr+ssh://bazaar.launchpad.net/~scmproj-dev/bzr-scmproj/trunk/
  parent branch: bzr+ssh://bazaar.launchpad.net/~scmproj-dev/bzr-scmproj/trunk/
  submit branch: C:/work/Bazaar/repos/scmproj-repo-1.9/0.4.5

C:\work\Bazaar\repos\scmproj-repo-1.9\trunk>bzr info -v
Repository tree (format: 1.9)
Location:
  shared repository: C:/work/Bazaar/repos/scmproj-repo-1.9
  repository branch: .

Related branches:
    push branch: bzr+ssh://bazaar.launchpad.net/~scmproj-dev/bzr-scmproj/trunk/
  parent branch: bzr+ssh://bazaar.launchpad.net/~scmproj-dev/bzr-scmproj/trunk/
  submit branch: C:/work/Bazaar/repos/scmproj-repo-1.9/0.4.5

Format:
       control: Meta directory format 1
  working tree: Working tree format 4
        branch: Branch format 7
    repository: Packs 6 (uses btree indexes, requires bzr 1.9)
bzr: ERROR: bzrlib.errors.NoSuchRevision: BzrBranch7('file:///C:/work/Bazaar/repos/scmproj-repo-1.9/trunk/') has no revision bia
<email address hidden>

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 842, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1037, in run_bzr
  File "bzrlib\commands.pyo", line 654, in run_argv_aliases
  File "bzrlib\commands.pyo", line 1052, in ignore_pipe
  File "bzrlib\builtins.pyo", line 1469, in run
  File "bzrlib\info.pyo", line 352, in show_bzrdir_info
  File "bzrlib\info.pyo", line 380, in show_component_info
  File "bzrlib\info.pyo", line 234, in _show_missing_revisions_working
  File "bzrlib\decorators.pyo", line 138, in read_locked
  File "bzrlib\branch.pyo", line 2721, in revision_id_to_revno
NoSuchRevision: BzrBranch7('file:///C:/work/Bazaar/repos/scmproj-repo-1.9/trunk/') has no revision <email address hidden>
-wlxjvzkuj72ze9mi

bzr 2.0.3 on python 2.5.4 (Windows-XP-5.1.2600-SP3)
arguments: ['C:\\Program Files\\Bazaar\\bzr.EXE', 'info', '-v']
encoding: 'cp1251', fsenc: 'mbcs', lang: None
plugins:
  acad C:\work\Bazaar\plugins\acad [0.8.0]
  bzrtools C:\Program Files\Bazaar\plugins\bzrtools [2.0.1]
  colo C:\work\Bazaar\plugins\colo [0.0.2dev]
  explorer C:\work\Bazaar\plugins\explorer [0.11.0dev]
  fastimport C:\work\Bazaar\plugins\fastimport [0.9.0dev]
  format1 C:\work\Bazaar\plugins\format1 [unknown]
  launchpad C:\Program Files\Bazaar\plugins\launchpad [2.0.3]
  qbzr C:\work\Bazaar\plugins\qbzr [0.18.0dev]
  rebase C:\Program Files\Bazaar\plugins\rebase [0.5.4]
  scmproj C:\work\Bazaar\plugins\scmproj [0.5.2dev]
  svn C:\work\Bazaar\plugins\svn [1.0.2dev]
  x_bit C:\work\Bazaar\plugins\x_bit [1.0.0]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    ...

Read more...

Changed in bzr:
status: Incomplete → Confirmed
Alexander Belchenko (bialix) wrote :

C:\work\Bazaar\repos\scmproj-repo-1.9\trunk>bzr log -r-1 --show-ids
------------------------------------------------------------
revno: 341
revision-id: <email address hidden>
parent: <email address hidden>
committer: Alexander Belchenko <email address hidden>
branch nick: trunk
timestamp: Wed 2010-01-13 11:45:45 +0200
message:
  pcmd/pup/pback: --different-tips condition also checks for tags difference. Ditto for --equal-tips

Alexander Belchenko (bialix) wrote :

May be it's worth to mention that my branch tree is out of date:

C:\work\Bazaar\repos\scmproj-repo-1.9\trunk>bzr st
working tree is out of date, run 'bzr update'

Alexander Belchenko (bialix) wrote :

revision in the error message which bzr claims it can't find is the working tree tip revision. See screenshot.

Vincent Ladeuil (vila) wrote :

As discussed on IRC, the problem seems to be related to a working tree whose tip is now a dotted revno
in the branch history, see: http://launchpadlibrarian.net/38124517/qlog-bug-244291.png

Alexander Belchenko (bialix) wrote :

If I do `bzr update` then error goes away.

Vincent Ladeuil (vila) wrote :

Once the tree is updated, the errors disapears

Jelmer Vernooij (jelmer) on 2011-02-01
tags: added: info
Jelmer Vernooij (jelmer) on 2017-11-08
tags: added: check-for-breezy
Jelmer Vernooij (jelmer) on 2020-03-22
Changed in brz:
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers