Bad IBUs for Extract Recipes

Bug #1286655 reported by Philip on 2014-03-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brewtarget
Medium
Philip

Bug Description

Brewtarget reports the boil SG is 1.000 in the attached recipe, causing the IBUs to be 24 instead of 13. I suggest fixing by no longer using the boil sg, but rather the recipe sg, as John Palmer [1] states that the cause of the decrease in utilization is the ability of alpha acids to bind to wort proteins, which fall out in the break material. If the brewer properly boils, she will always get break material, so the batch OG seems more appropriate to estimate this effect.

[1] http://homebrew.stackexchange.com/questions/7343/does-wort-gravity-affect-hop-utilization

Philip (rocketman768) wrote :
Steven Pratt (spratt) wrote :

As a workaround, maybe "mashed" can be selected for the LME? This seems to give a reasonable Boil SG.

Steven Pratt (spratt) wrote :

In addition, steeping grains should contribute to the Boil SG. At the present time, they don't appear to impact the Boil SG.

Boil SG is especially important for "Extract (half boil)" where the SG is much higher during the boil (due to less water using the same amount of malt). For this reason, I don't believe the recipe OG should be used.

Philip (rocketman768) wrote :

Fixed in commit e883ec9.

Changed in brewtarget:
assignee: nobody → Philip (rocketman768)
status: New → In Progress
status: In Progress → Fix Committed
summary: - Boil SG 1.000 in Extract Recipes
+ Bad IBUs for Extract Recipes
Philip (rocketman768) on 2014-09-20
Changed in brewtarget:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers