brewtarget won't launch OSX with case sensitive FS

Bug #1259374 reported by eyko on 2013-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brewtarget
Low
Philip

Bug Description

Brewtarget will fail to open when opened from a case sensitive filesystem. If you're on a case insensitive FS and want to reproduce, you can create a cAsE sEnSiTiVe image (dmg) and put Brewtarget.app on there. When you try to run it, it will fail.

If you try running from the terminal, the error message says: The application cannot be opened because its executable is missing.

If you try double clicking it, the error message says: You can't open the application "brewtarget" because it may be damaged or incomplete.

Running from the dmg provided in the download page works (because it is not a case sensitive filesystem).

To fix: update Info.plist here http://bazaar.launchpad.net/~rocketman768/brewtarget/master/view/head:/mac/Info.plist#L21 and change Brewtarget for brewtarget (all lowercase) since that's what the executable is called.

Tags: osx Edit Tag help
Philip (rocketman768) on 2014-08-03
Changed in brewtarget:
milestone: none → 2.1.0
assignee: nobody → Philip (rocketman768)
importance: Undecided → Low
Philip (rocketman768) wrote :

Fixed in commit ba51202.

Changed in brewtarget:
status: New → Fix Committed
Philip (rocketman768) on 2014-09-20
Changed in brewtarget:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers