Building brewtarget when Qt is compiled with -no-phonon doesn't work

Bug #1212921 reported by Mik Firestone on 2013-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brewtarget
Medium
Mik Firestone

Bug Description

G:\brewtarget\src\TimerWidget.cpp: In constructor 'TimerWidget::TimerWidget(QWidget*)':
G:\brewtarget\src\TimerWidget.cpp:73:13: error: 'mediaObject' was not declared in this scope
G:\brewtarget\src\TimerWidget.cpp: In member function 'void TimerWidget::startStop()':
G:\brewtarget\src\TimerWidget.cpp:221:7: error: 'mediaObject' was not declared in this scope
mingw32-make[2]: *** [src/CMakeFiles/brewtarget.dir/TimerWidget.cpp.obj] Error 1
mingw32-make[1]: *** [src/CMakeFiles/brewtarget.dir/all] Error 2

Mik Firestone (mikfire) wrote :

This seems to be caused by attaching and detach a signal for an object which is not declared due to an ifdef. The attach/detach simply needs to be put in the appropriate ifdef

Changed in brewtarget:
status: New → Triaged
Mik Firestone (mikfire) wrote :

Fixed in merge request 47.

Changed in brewtarget:
status: Triaged → Fix Committed
Philip (rocketman768) on 2013-08-18
Changed in brewtarget:
milestone: none → 2.0.2
Philip (rocketman768) on 2014-02-02
Changed in brewtarget:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers