EBC value divided by 2

Bug #1170088 reported by Andre Bischof on 2013-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brewtarget
Medium
Mik Firestone

Bug Description

I'm using brewtarget 2.0.0 for Windows.
Whenever I open the fermentable editor on an fermentable,
the colot/EBC is automatically modified. The new EBC value is the original one divided by 2.
For example, I have defined some malt with EBC=8.
When open the editor on this malt, the EBC is changed to 4.1.
If I save the new setting, and then open again, the value is changed again (to 2).

This is quite annoying, especially when I want to adjust some parameter (like yield),
and then accidently change EBC value as well.

Mik Firestone (mikfire) on 2013-05-09
Changed in brewtarget:
status: New → Confirmed
assignee: nobody → Mik Firestone (mikfire)
importance: Undecided → Medium

Dear Mik,

I have found another EBC related issue:
When I print the recipe, the beer color is in lovibond, not EBC, even though I have chosen EBC as color unit.

Best regards
André

________________________________
 From: Mik Firestone <email address hidden>
To: <email address hidden>
Sent: Thursday, May 9, 2013 3:04 PM
Subject: [Bug 1170088] Re: EBC value divided by 2

** Changed in: brewtarget
      Status: New => Confirmed

** Changed in: brewtarget
    Assignee: (unassigned) => Mik Firestone (mikfire)

** Changed in: brewtarget
  Importance: Undecided => Medium

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1170088

Title:
  EBC value divided by 2

Status in Brewtarget:
  Confirmed

Bug description:
  I'm using brewtarget 2.0.0 for Windows.
  Whenever I  open the fermentable editor on an fermentable,
  the colot/EBC is automatically modified. The new EBC value is the original one divided by 2.
  For example, I have defined some malt with EBC=8.
  When open the editor on this malt, the EBC is changed to 4.1.
  If I save the new setting, and then open again,  the value is changed again (to 2).

  This is quite annoying, especially when I want to adjust some parameter (like yield),
  and then accidently change EBC value as well.

To manage notifications about this bug go to:
https://bugs.launchpad.net/brewtarget/+bug/1170088/+subscriptions

Mik Firestone (mikfire) wrote :

Cool. I will look into that too. I have a patch ready to go for the
original problem, but I am fighting (as usual) with git.

Mik

On Fri, May 10, 2013 at 2:02 PM, Andre Bischof <email address hidden>wrote:

> Dear Mik,
>
> I have found another EBC related issue:
> When I print the recipe, the beer color is in lovibond, not EBC, even
> though I have chosen EBC as color unit.
>
> Best regards
> André
>
>
>
> ________________________________
> From: Mik Firestone <email address hidden>
> To: <email address hidden>
> Sent: Thursday, May 9, 2013 3:04 PM
> Subject: [Bug 1170088] Re: EBC value divided by 2
>
>
> ** Changed in: brewtarget
> Status: New => Confirmed
>
> ** Changed in: brewtarget
> Assignee: (unassigned) => Mik Firestone (mikfire)
>
> ** Changed in: brewtarget
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1170088
>
> Title:
> EBC value divided by 2
>
> Status in Brewtarget:
> Confirmed
>
> Bug description:
> I'm using brewtarget 2.0.0 for Windows.
> Whenever I open the fermentable editor on an fermentable,
> the colot/EBC is automatically modified. The new EBC value is the
> original one divided by 2.
> For example, I have defined some malt with EBC=8.
> When open the editor on this malt, the EBC is changed to 4.1.
> If I save the new setting, and then open again, the value is changed
> again (to 2).
>
> This is quite annoying, especially when I want to adjust some parameter
> (like yield),
> and then accidently change EBC value as well.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/brewtarget/+bug/1170088/+subscriptions
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: brewtarget-bug
> https://bugs.launchpad.net/bugs/1170088
>
> Title:
> EBC value divided by 2
>
> Status in Brewtarget:
> Confirmed
>
> Bug description:
> I'm using brewtarget 2.0.0 for Windows.
> Whenever I open the fermentable editor on an fermentable,
> the colot/EBC is automatically modified. The new EBC value is the
> original one divided by 2.
> For example, I have defined some malt with EBC=8.
> When open the editor on this malt, the EBC is changed to 4.1.
> If I save the new setting, and then open again, the value is changed
> again (to 2).
>
> This is quite annoying, especially when I want to adjust some parameter
> (like yield),
> and then accidently change EBC value as well.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/brewtarget/+bug/1170088/+subscriptions
>

--
In a world of ninja v. pirate, I pilot a Gundam

Mik Firestone (mikfire) wrote :

Should be fixed in merge request 39. Both problem were symptoms of the same bug. Thanks for reporting them, because otherwise I wouldn't have thought to look for the deeper cause.

Changed in brewtarget:
status: Confirmed → Fix Committed
Philip (rocketman768) on 2013-05-18
Changed in brewtarget:
milestone: none → 2.0.2
Philip (rocketman768) on 2014-02-02
Changed in brewtarget:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers