autogen.sh fails: Package 'gee-1.0', required by 'virtual:world', not found

Bug #1791648 reported by Oscar Megía López on 2018-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Break Timer
Undecided
Unassigned

Bug Description

Hi

I'm trying to build gnome-break-timer to make some changes. I have Archlinux x86_64 with linux version 4.18.6-arch1-1-ARCH and I get an error. This is the error output:
...
checking for CFG_CORE... no
configure: error: Package requirements (
 glib-2.0 >= 2.36.0
 gobject-2.0 >= 2.36.0
 gee-1.0 >= 0.6.2
 gio-2.0 >= 2.30.0
 gio-unix-2.0 >= 2.30.0
 gtk+-3.0 >= 3.10.0
 json-glib-1.0 >= 0.16.0
) were not met:

Package 'gee-1.0', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CFG_CORE_CFLAGS
and CFG_CORE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
...

I have installed libgee:
[oscar@minitorre gnome-break-timer.ssh]$ LC_ALL=C pacman -Qi libgee
Name : libgee
Version : 0.20.1-2
Description : A collection library providing GObject-based interfaces and classes for commonly used data structures
Architecture : x86_64
URL : https://git.gnome.org/browse/libgee
Licenses : LGPL2.1
Groups : None
Provides : None
Depends On : glib2
Optional Deps : None
Required By : folks gedit-code-assistance gitg gnome-2048 gnome-break-timer gnome-code-assistance gnome-contacts gnome-maps
                  gnome-nibbles gnome-sudoku libgnome-games-support rygel
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1489.00 KiB
Packager : Jan Alexander Steffens (heftig) <email address hidden>
Build Date : Fri Apr 13 21:55:57 2018
Install Date : Sat Apr 28 14:46:15 2018
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

libgee /usr/
libgee /usr/include/
libgee /usr/include/gee-0.8/
libgee /usr/include/gee-0.8/gee.h
libgee /usr/lib/
libgee /usr/lib/girepository-1.0/
libgee /usr/lib/girepository-1.0/Gee-0.8.typelib
libgee /usr/lib/libgee-0.8.so
libgee /usr/lib/libgee-0.8.so.2
libgee /usr/lib/libgee-0.8.so.2.6.1
libgee /usr/lib/pkgconfig/
libgee /usr/lib/pkgconfig/gee-0.8.pc
libgee /usr/share/
libgee /usr/share/gir-1.0/
libgee /usr/share/gir-1.0/Gee-0.8.gir
libgee /usr/share/vala/
libgee /usr/share/vala/vapi/
libgee /usr/share/vala/vapi/gee-0.8.vapi
[oscar@minitorre gnome-break-timer.ssh]$

But I can't install neither package gee nor gee-1.0:

[oscar@minitorre gnome-break-timer.ssh]$ LC_ALL=C sudo pacman -S gee
error: target not found: gee
[oscar@minitorre gnome-break-timer.ssh]$ LC_ALL=C sudo pacman -S gee-1.0
error: target not found: gee-1.0
[oscar@minitorre gnome-break-timer.ssh]$

Any idea how can I solve this issue?

Regards
Oscar

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers