autogen fails: possibly undefined macro: AC_CHECK_LIBM

Bug #1233203 reported by David Clymer on 2013-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Break Timer
Undecided
David Clymer

Bug Description

OS: Debian 7.1 (Wheezy)

Steps:

david_clymer@professorx:~/Downloads/src$ git clone https://git.gnome.org/browse/gnome-break-timer/
Cloning into 'gnome-break-timer'...
remote: Counting objects: 2517, done.
remote: Compressing objects: 100% (1673/1673), done.
remote: Total 2517 (delta 1021), reused 2153 (delta 801)
Receiving objects: 100% (2517/2517), 1.42 MiB | 591 KiB/s, done.
Resolving deltas: 100% (1021/1021), done.
david_clymer@professorx:~/Downloads/src$ cd gnome-break-timer/
david_clymer@professorx:~/Downloads/src/gnome-break-timer$ ls
AUTHORS autogen.sh base.am common configure.ac config.vapi COPYING data gnome-break-timer.doap helper libgd Makefile.am NEWS po README settings tests
david_clymer@professorx:~/Downloads/src/gnome-break-timer$ ./autogen.sh 2> autogen-err.log > autogen-out.log
david_clymer@professorx:~/Downloads/src/gnome-break-timer$ cat autogen-err.log
autoreconf: Entering directory `.'
autoreconf: running: intltoolize --automake --copy --force
autoreconf: running: aclocal --force -I m4 -I libgd
configure.ac:71: warning: LT_INIT is m4_require'd but not m4_defun'd
libgd/libgd.m4:34: LIBGD_INIT is expanded from...
configure.ac:71: the top level
configure.ac:71: warning: AC_CHECK_LIBM is m4_require'd but not m4_defun'd
libgd/libgd.m4:34: LIBGD_INIT is expanded from...
configure.ac:71: the top level
autoreconf: configure.ac: tracing
configure.ac:71: warning: LT_INIT is m4_require'd but not m4_defun'd
libgd/libgd.m4:34: LIBGD_INIT is expanded from...
configure.ac:71: the top level
configure.ac:71: warning: AC_CHECK_LIBM is m4_require'd but not m4_defun'd
libgd/libgd.m4:34: LIBGD_INIT is expanded from...
configure.ac:71: the top level
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:71: warning: LT_INIT is m4_require'd but not m4_defun'd
libgd/libgd.m4:34: LIBGD_INIT is expanded from...
configure.ac:71: the top level
configure.ac:71: warning: AC_CHECK_LIBM is m4_require'd but not m4_defun'd
libgd/libgd.m4:34: LIBGD_INIT is expanded from...
configure.ac:71: the top level
configure:7432: error: possibly undefined macro: AC_CHECK_LIBM
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
configure: error: cannot find install-sh, install.sh, or shtool in "." "./.." "./../.."
david_clymer@professorx:~/Downloads/src/gnome-break-timer$ autoconf -V
autoconf (GNU Autoconf) 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille.

David Clymer (vezult) wrote :

libtool was not installed.

Changed in brainbreak:
assignee: nobody → David Clymer (vezult)
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers