mini.iso installer cannot load additional components

Bug #1403982 reported by sudodus on 2014-12-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apt (BOSS)
High
sand honers
debian-installer (BOSS)
Undecided
Unassigned

Bug Description

system: Ubuntu Vivid 32-bit current daily mini.iso

Computer: http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

Dialogue:

"Choose a mirror to use and press enter.

If you have a http proxy type its details now, otherwise just press enter."

The installer does not start loading additional components. Instead it complains:
"Downloading a file failed"
Retry
Change mirror
Cancel

I have tried several national mirrors, and also 'archive.ubuntu.com'

No mirror can provide that file, and the installation gets stuck here.

Failing process: udpkg, net-retriever, or maybe missing files in the mirrors?

There is nothing wrong with my internet connection:
ping ubuntu.com works (from this Vivid alpha mini.iso)
Ubuntu 14.04 LTS mini.iso works, can install systems

The automatically attached files have nothing to do with the bug. They were created in another computer because I could not create the report in the simple system running in the beginning of the mini.iso installation process. So they were removed.

ProblemType: Bug
DistroRelease: Ubuntu mini.iso 15.04
version 20101020ubuntu356/ 16-Dec-2014 01:28

Architecture: i386
Date: Thu Dec 18 19:23:55 2014
MarkForUpload: True
PackageArchitecture: all

sudodus (nio-wiklund) on 2014-12-18
description: updated
sudodus (nio-wiklund) on 2014-12-18
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

Not seeing that error - I get a No Kernel Modules found warning.

Elfy (elfy) wrote :
sudodus (nio-wiklund) wrote :

I have been testing the version found in

http://www.fr.php.net/ubuntu/dists/vivid/main/installer-i386/current/images/netboot/

[DIR] 20101020ubuntu354/ 30-Oct-2014 10:08 -
[DIR] 20101020ubuntu355/ 24-Nov-2014 23:28 -
[DIR] 20101020ubuntu356/ 16-Dec-2014 01:28 -
[DIR] current/ 16-Dec-2014 01:28 -

In other words, version 356

description: updated
Elfy (elfy) wrote :

seems to be bad sigs - see screenshot

sudodus (nio-wiklund) wrote :

In screen 4 I get

/tmp/net-retriever-2315-Release.gpg
gpgv: md_enable: algorithm 10 not available
Signature made ...
gpgv: Can't check signature: unknown unknown digest algorithm
...

I've just hit this trying to do a netinstall of vivid.

Looking at the source, algorithm 10 is sha512. The binary for the installer is built with --enable-minimal, which disables sha512, but then it isn't specifically enabled. Attached patch to enable it.
I've tested this by building it myself and using wget to replace the included binary with mine, I successfully completed the install.

Changed in gnupg (Ubuntu):
status: New → Confirmed
tags: added: vivid
removed: precise
tags: added: patch
Changed in update-manager (Ubuntu):
importance: Undecided → High
Changed in gnupg (Ubuntu):
importance: Undecided → High

The attachment "gnupg-1.4.18 enable sha512 for minimal.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

futurefx (force) wrote :

i hope it is fixed, current vivid mini.iso are useless and cannot be used because of this.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1403982

tags: added: iso-testing
no longer affects: update-manager (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnupg - 1.4.18-4ubuntu2

---------------
gnupg (1.4.18-4ubuntu2) vivid; urgency=medium

  * Enable SHA-512 support in gpgv-udeb, since Ubuntu's Release.gpg is
    signed using that digest algorithm (thanks, Nathan Rennie-Waldock;
    LP: #1403982).
 -- Colin Watson <email address hidden> Wed, 14 Jan 2015 11:23:40 +0000

Changed in gnupg (Ubuntu):
status: Confirmed → Fix Released
sudodus (nio-wiklund) wrote :

I downloaded the mini.iso today from

http://archive.ubuntu.com/ubuntu/dists/vivid/main/installer-i386/20101020ubuntu359/images/netboot/mini.iso

dialogue: 'The installer failed to download a file from the mirror'
screen 4: 'Can't check signature: unknown digest signature', so I think the bug is still there.

-o-

The bug fix is not yet available at the link from the iso tracker

Where/when is the fixed mini.iso available?

Installer hasn't been rebuilt yet. Hopefully someone will do it soon.

Breno Leitão (breno-leitao) wrote :

As I understand, a new release of debian-installer will include this fix (that is actually at gnupg). So, let's wait the new release of debian-installer.

There's a workaround available meanwhile -- if you want to use the currently available netboot image, and can afford skipping the GPG checks/its implications.

Append this to the kernel command line: debian-installer/allow_unauthenticated=true

sudodus (nio-wiklund) wrote :

Thanks for the tip :-)

It should be OK for testing purposes (for example iso testing the vivid alpha 2 this due this week)

sudodus (nio-wiklund) wrote :

Sorry, I failed doing it. I know how to add boot options in syslinux and grub2 for the desktop installers, but this one beat me.

I pressed TAB and got this line:

> linux vga=788 initrd=initrd.gz -- quiet

and I appended

debian-installer/allow_unauthenticated=true

also tried

allow_unauthenticated=true

and

debian-installer.allow_unauthenticated=true

(syntax according to a tip in the help menu)

but no go.

sudodus (nio-wiklund) wrote :

mini.iso dated 2015-01-22 from

http://archive.ubuntu.com/ubuntu/dists/vivid/main/installer-i386/20101020ubuntu360/images/

with md5sum
79905f6372c83ad0da93cb25015029f9 ./netboot/mini.iso
works.

This red bug is squashed, and the solution has trickled down to me, a simple iso-tester :-)

@nio-wiklund

Hi, not sure why it didn't work for your cmdline.

If you're still interested in debugging, the option you entered is correct,
as you can see on net-retriever source code:

if db_get debian-installer/allow_unauthenticated && [ "$RET" = true ]; then
   log "Not verifying Release signature: unauthenticated mode enabled"
else

(net-retriever_1.39ubuntu1.tar.xz, file net-retriever/net-retriever, line 204)
https://launchpad.net/ubuntu/vivid/+source/net-retriever

sudodus (nio-wiklund) wrote :

Well the mini.iso works now (without your work-around), but anyway it is good to know how to add such a work-around :-)

Please describe where and how to add that command! What should be booted and at what stage should it be entered?

What is db_get ?

Should I use some other way to get the 'minimal install' (not by downloading and booting the mini.iso)?

You can find more info about that in preseed, debian installer options. Basically boot options taken by the installer.

Since there are multiple reports that this is fixed; closing the debian-installer bug as Invalid. (Fixed, but wasn't a bug in d-i)

As for the workaround, that too should be fixed (was bug 1427252)

Changed in debian-installer (Ubuntu):
status: New → Invalid
Changed in gnupg (Ubuntu):
assignee: nobody → sand honers (sandhoners123)
affects: gnupg (Ubuntu) → gnupg (BOSS)
affects: gnupg (BOSS) → boss
affects: boss → apt (BOSS)
Changed in debian-installer (Ubuntu):
status: Invalid → Fix Released
affects: debian-installer (Ubuntu) → debian-installer (BOSS)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers