command for linux-generic fails when only other kernels available

Bug #1666781 reported by Aaron Wolf on 2017-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Boot-Repair
Low
YannUbuntu

Bug Description

Boot-repair failed for me (resulted in loading to grub prompt) because it told me to enter a command with "linux-generic" as the kernel. My system has no linux-generic installed. It only has linux-lowlatency. When I ran the repair again and changed that command, it succeeded.

Ideally, the program should see what kernels are available and make sure not to specify one that isn't there.

Aaron Wolf (wolftune) wrote :

I should add that the command seemed to work, and everything said it was fine until the final end that said there were errors but I could try to reboot anyway. I think that it said there were errors when I used the linux-lowlatency substitute also, except then I booted successfully. So, I had to reboot a couple times and redo the whole process before I determined this problem and solution.

YannUbuntu (yannubuntu) wrote :

hi Aaron, thx for the report and sorry for the late answer.
Which OS did you try to repair ?

Aaron Wolf (wolftune) wrote :

At the time, I was either running KXStudio 14.04 which is just a derivative of Ubuntu or was running KDE Neon (which I use now). Either way, it's basically plain Ubuntu on the kernel level. I had simply installed the low-latency variant and removed the generic. That was probably something I did and not default for those systems.

Of course, if the UI had simply provided the correct commands, then boot-repair would have worked without any confusion, even in my circumstance.

In other words: you can reproduce by installing plain Ubuntu, install low-latency kernel, remove generic, (and I suppose purposely mess up GRUB to really be at the same experience).

YannUbuntu (yannubuntu) wrote :

ok thx Aaron.

Changed in boot-repair:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → YannUbuntu (yannubuntu)
YannUbuntu (yannubuntu) wrote :

should be fixed in 4ppa48

Changed in boot-repair:
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers