Please recommend mawk (>= 1.3.4) | gawk packages instead of exact gawk

Bug #1331381 reported by Mantas Kriaučiūnas on 2014-06-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Boot-Repair
Wishlist
Unassigned

Bug Description

boot-repair currently recommends gawk package, but on Ubuntu as default is installed faster and smaller mawk since 2005 !

boot-repair should recommend "mawk (>= 1.3.4) | gawk" if old mawk 1.3.3 is buggy and couses problems.

You could add this fix in next boot-repair release, please don't wait when mawk is updated in Ubuntu - I've reported the same bug 2 years ago (see bug #1005077) because currently isn't clear why mawk can't be used.

YannUbuntu (yannubuntu) wrote :

thanks for the suggestion.
mawk 1.3.3 is buggy, that makes errors in BootInfo.
As long as Ubuntu does not come with 1.3.4 ( http://invisible-island.net/mawk/ ) by default, Boot-Repair should keep gawk as dependency to avoid such errors.

YannUbuntu (yannubuntu) wrote :

setting as Invalid for the moment. Please re-open when mawk is updated in Ubuntu.

Changed in boot-repair:
status: New → Invalid
summary: - Please recommend awk or mawk | gawk packages instead of exact gawk
+ Please recommend mawk (>= 1.3.4) | gawk packages instead of exact gawk
description: updated
Changed in boot-repair:
status: Invalid → Confirmed
YannUbuntu (yannubuntu) on 2014-06-20
Changed in boot-repair:
importance: Undecided → Wishlist
status: Confirmed → Triaged
YannUbuntu (yannubuntu) wrote :

will be fixed in version 4ppa12.

Changed in boot-repair:
status: Triaged → Fix Committed
YannUbuntu (yannubuntu) on 2014-11-28
Changed in boot-repair:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers